Bug 216077 - games/vamos: fails to build with lang/gcc6 or later
Summary: games/vamos: fails to build with lang/gcc6 or later
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Steve Wills
URL:
Keywords: needs-patch
Depends on:
Blocks: 224669
  Show dependency treegraph
 
Reported: 2017-01-14 16:12 UTC by Jan Beich
Modified: 2018-05-27 22:19 UTC (History)
1 user (show)

See Also:


Attachments
svn-diff-games_vamos (355 bytes, patch)
2018-02-11 23:21 UTC, Walter Schwarzenfeld
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2017-01-14 16:12:57 UTC
XML_Parser.cc:394:39: error: invalid operands to binary expression ('std::ifstream' (aka 'basic_ifstream<char>') and 'int')
  if ((mp_stream == 0) || (*mp_stream == 0))
                           ~~~~~~~~~~ ^  ~
Ac3d.cc:894:9: error: invalid operands to binary expression ('std::ifstream' (aka 'basic_ifstream<char>') and 'int')
        if (is == 0)
            ~~ ^  ~

build log: http://sprunge.us/RQDJ
regressed by: https://github.com/llvm-mirror/libcxx/commit/3a1b90a866b6
Comment 1 Jan Beich freebsd_committer 2017-01-14 16:16:25 UTC
(In reply to Dimitry Andric from bug 216034 comment #6)
> Note that the upstream author has reverted the commit causing this here:
>
> http://llvm.org/viewvc/llvm-project?rev=291921&view=rev
>
> and has also merged it to the 4.0 branch. I will import the upstream
> branch into the projects/clang400-import branch soon.

lang/gcc6 and later versions are also affected.

XML_Parser.cc: In member function 'void Vamos_Media::XML_Parser::read(std::__cxx11::string)':
XML_Parser.cc:394:39: error: no match for 'operator==' (operand types are 'std::ifstream {aka std::basic_ifstream<char>}' and 'int')
   if ((mp_stream == 0) || (*mp_stream == 0))
                            ~~~~~~~~~~~^~~~
Ac3d.cc: In constructor 'Vamos_Media::Ac3d::Ac3d(std::__cxx11::string, double, const Vamos_Geometry::Three_Vector&, const Vamos_Geometry::Three_Vector&)':
Ac3d.cc:894:9: error: no match for 'operator==' (operand types are 'std::ifstream {aka std::basic_ifstream<char>}' and 'int')
  if (is == 0)
      ~~~^~~~
Comment 2 Jan Beich freebsd_committer 2018-01-12 13:45:55 UTC
Clang 6 defaults to C++14, so pkg-fallout@ will complain soon.
Comment 3 Walter Schwarzenfeld freebsd_triage 2018-02-11 23:21:17 UTC
Created attachment 190532 [details]
svn-diff-games_vamos
Comment 4 Walter Schwarzenfeld freebsd_triage 2018-05-26 13:55:36 UTC
Update to vamos 0.8.2 available, but the problem is the same.
Comment 5 commit-hook freebsd_committer 2018-05-27 22:18:20 UTC
A commit references this bug:

Author: swills
Date: Sun May 27 22:17:59 UTC 2018
New revision: 471010
URL: https://svnweb.freebsd.org/changeset/ports/471010

Log:
  games/vamos: fix build with lang/gcc6 or later

  PR:		216077
  Submitted by:	w.schwarzenfeld@utanet.at
  Reported by:	jbeich

Changes:
  head/games/vamos/Makefile
Comment 6 Steve Wills freebsd_committer 2018-05-27 22:19:21 UTC
Committed, thanks!