Bug 222605 - multimedia/audacious-gtk3: Update to 3.9
Summary: multimedia/audacious-gtk3: Update to 3.9
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Thomas Zander
URL:
Keywords: patch-ready
Depends on: 222603
Blocks: 222606
  Show dependency treegraph
 
Reported: 2017-09-25 20:45 UTC by Olivier Duchateau
Modified: 2017-09-30 13:25 UTC (History)
1 user (show)

See Also:


Attachments
Patch to update multimedia/audacious-gtk3 (1.73 KB, patch)
2017-09-25 20:45 UTC, Olivier Duchateau
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Duchateau 2017-09-25 20:45:47 UTC
Created attachment 186719 [details]
Patch to update multimedia/audacious-gtk3

- Update to 3.9
- Adjust dependencies (remove dbus-glib), now it uses gdbus-codegen (from GLib20)
- Use GitHub host because tarball is not available on audacious-media-player.org site

Note: with portlint GITHUB macros needs to be placed after USES. For me it's totally wrong (not coherent with MASTER_SITES definition).
Comment 1 commit-hook freebsd_committer 2017-09-30 13:22:25 UTC
A commit references this bug:

Author: riggs
Date: Sat Sep 30 13:21:32 UTC 2017
New revision: 450993
URL: https://svnweb.freebsd.org/changeset/ports/450993

Log:
  Update to upstream version 3.9

  PR:		222605
  Submitted by:	duchateau.olivier@gmail.com

Changes:
  head/multimedia/audacious-gtk3/Makefile
  head/multimedia/audacious-gtk3/distinfo