Bug 224055 - www/firefox: Build fails with non-default python
Summary: www/firefox: Build fails with non-default python
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-gecko (Nobody)
URL:
Keywords:
: 224012 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-12-03 13:44 UTC by Peter Wullinger
Modified: 2018-01-27 00:01 UTC (History)
2 users (show)

See Also:
jbeich: maintainer-feedback+


Attachments
build fix patch (690 bytes, patch)
2017-12-03 13:44 UTC, Peter Wullinger
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Wullinger 2017-12-03 13:44:39 UTC
Created attachment 188492 [details]
build fix patch

Trying to build with

DEFAULT_VERSIONS += python=3.6

breaks on me with

[portbuild-py36-default-job-04] Extracting py36-sqlite3-3.6.3_7: ........ done
===>   firefox-57.0.1,1 depends on package: py27-sqlite3>0 - not found

Applying the attached patch fixes the problem for me:

- build-depend on ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
- explicitly set USES=python:2,build
Comment 1 commit-hook freebsd_committer 2017-12-03 17:36:08 UTC
A commit references this bug:

Author: jbeich
Date: Sun Dec  3 17:35:30 UTC 2017
New revision: 455413
URL: https://svnweb.freebsd.org/changeset/ports/455413

Log:
  gecko: unbreak with non-default python version after r455210

  $ make
  [...]
  Installing py36-sqlite3-3.6.3_7...
  ===>   firefox-57.0.1,1 depends on package: py27-sqlite3>0 - not found
  *** Error code 1

  PR:		224055
  Submitted by:	Peter Wullinger

Changes:
  head/mail/thunderbird/Makefile
  head/www/firefox/Makefile
  head/www/firefox-esr/Makefile
  head/www/libxul/Makefile
  head/www/palemoon/Makefile
  head/www/seamonkey/Makefile
  head/www/waterfox/Makefile
Comment 2 Jan Beich freebsd_committer 2017-12-03 17:40:43 UTC
Thank you for reporting. I guess, ports r455210 mechanically converted only files with explicit USES=python, a subset of those using PYTHON_PKGNAMEPREFIX.

(In reply to Peter Wullinger from comment #0)
> - explicitly set USES=python:2,build

Mk/bsd.gecko.mk already has USES=python:2.7,build
Comment 3 Jan Beich freebsd_committer 2017-12-07 00:19:38 UTC
*** Bug 224012 has been marked as a duplicate of this bug. ***
Comment 4 Bryan Drewery freebsd_committer 2018-01-23 20:39:22 UTC
(In reply to Jan Beich from comment #2)
> Thank you for reporting. I guess, ports r455210 mechanically converted only
> files with explicit USES=python, a subset of those using
> PYTHON_PKGNAMEPREFIX.
> 
> (In reply to Peter Wullinger from comment #0)
> > - explicitly set USES=python:2,build
> 
> Mk/bsd.gecko.mk already has USES=python:2.7,build

~/svn/ports # make -C www/firefox -V 'BUILD_DEPENDS:M*sqlite*' -V 'USES:M*python*' -V PYTHON_DEFAULT
sqlite3>=3.20.1:databases/sqlite3 py27-sqlite3>0:databases/py-sqlite3@py27
python:2.7,build
3.6


My default python is 3.6 and yet firefox is forcing a 2.7 dependency for sqlite.
Is that correct? Just making sure since I had a bug reported about poudriere with non-default python and noticed it.