Bug 225649 - sysutils/apachetop: Unbreak build with Clang 6 (C++14 by default)
Summary: sysutils/apachetop: Unbreak build with Clang 6 (C++14 by default)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-03 16:24 UTC by Lukasz Wasikowski
Modified: 2018-08-27 07:15 UTC (History)
1 user (show)

See Also:


Attachments
Patch unbreaking apachetop with Clang 6 (572 bytes, patch)
2018-02-03 16:24 UTC, Lukasz Wasikowski
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lukasz Wasikowski 2018-02-03 16:24:28 UTC
Created attachment 190299 [details]
Patch unbreaking apachetop with Clang 6

Patch to unbreak build with Clang 6 for games/oolite port. Caused by base r327952 changes.

The Clang 6 uses -std=gnu++14 for C++ files by default:
https://github.com/llvm-mirror/clang/commit/466d8da5f89b1a780f735c86f414fa69ce63221b

Reported by pkg-fallout (FreeBSD 12.0-CURRENT 1200056 amd64):
http://beefy12.nyi.freebsd.org/data/head-amd64-default/p460549_s328647/logs/apachetop-0.12.6_5.log

- Add USE_CXXSTD=gnu++98
- Add LICENCE=BSD
- Changed MASTER_SITES to new https address

The PORTREVISION bump is not required.
Comment 1 commit-hook freebsd_committer 2018-02-04 09:45:08 UTC
A commit references this bug:

Author: danfe
Date: Sun Feb  4 09:44:24 UTC 2018
New revision: 460880
URL: https://svnweb.freebsd.org/changeset/ports/460880

Log:
  - Fix some sloppy coding that was upsetting new Clang
  - Switch MASTER_SITES to https:// and add LICENSE

  PR:		225649 (modified)
  Submitted by:	maintainer

Changes:
  head/sysutils/apachetop/Makefile
  head/sysutils/apachetop/files/patch-src_apachetop.cc
  head/sysutils/apachetop/files/patch-src_display.cc
  head/sysutils/apachetop/files/patch-src_hits__circle.cc
  head/sysutils/apachetop/files/patch-src_log.cc
Comment 2 Alexey Dokuchaev freebsd_committer 2018-02-04 09:46:25 UTC
Port was fixed as or ports r460880 (rather than forcing gnu++98, I've simply fixed the bad code).
Comment 3 commit-hook freebsd_committer 2018-02-04 15:09:42 UTC
A commit references this bug:

Author: danfe
Date: Sun Feb  4 15:09:38 UTC 2018
New revision: 460934
URL: https://svnweb.freebsd.org/changeset/ports/460934

Log:
  Fix previous commit (r460880): maintainer had requested not simply switch
  to https:// for MASTER_SITES, but a new URL as well.  While here, improve
  on the COMMENT and port description.

  PR:	225649

Changes:
  head/sysutils/apachetop/Makefile
  head/sysutils/apachetop/pkg-descr