Bug 228708 - www/qt5-webengine 5.9.5: Does not build on armv7
Summary: www/qt5-webengine 5.9.5: Does not build on armv7
Status: Closed DUPLICATE of bug 228603
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm Any
: --- Affects Some People
Assignee: kde
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-02 18:17 UTC by Ulrich Grey
Modified: 2018-06-06 13:53 UTC (History)
4 users (show)

See Also:


Attachments
Poudriere build log (96.86 KB, text/plain)
2018-06-02 18:17 UTC, Ulrich Grey
no flags Details
Successful build log (96.86 KB, text/plain)
2018-06-04 15:30 UTC, Ulrich Grey
no flags Details
Successful build log (200.98 KB, application/gzip)
2018-06-04 15:49 UTC, Ulrich Grey
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrich Grey 2018-06-02 18:17:45 UTC
Created attachment 193948 [details]
Poudriere build log

I am building ports on my wandboard-quad running

FreeBSD 12.0-CURRENT #0 r333645

[23/16191] CXX obj/base/third_party/symbolize/symbolize/symbolize.o
FAILED: obj/base/third_party/symbolize/symbolize/symbolize.o 
/usr/local/libexec/ccache/c++ -B/usr/local/bin -MMD -MF obj/base/third_party/symbolize/symbolize/symbolize.o.d -DV8_DEPRECATION_WARNINGS -DENABLE_PLUGINS=1 -DUSE_AURA=1 -DUSE_GLIB=1 -DUSE_NSS_CERTS=1 -DUSE_X11=1 -DNO_TCMALLOC -DDISABLE_NACL -DENABLE_TASK_MANAGER=1 -DENABLE_THEMES=1 -DUSE_PROPRIETARY_CODECS -DFULL_SAFE_BROWSING -DSAFE_BROWSING_CSD -DSAFE_BROWSING_DB_LOCAL -DCHROMIUM_BUILD -DFIELDTRIAL_TESTING_ENABLED -DTOOLKIT_QT -DCR_CLANG_REVISION=284979-2 -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -DNDEBUG -DNVALGRIND -DDYNAMIC_ANNOTATIONS_ENABLED=0 -Igen -I../../../../qtwebengine-opensource-src-5.9.5/src/3rdparty/chromium -fno-strict-aliasing --param=ssp-buffer-size=4 -fstack-protector -Wno-unknown-attributes -Wno-unknown-warning-option -funwind-tables -fPIC -pipe -fcolor-diagnostics -fdebug-prefix-map=/wrkdirs/usr/ports/www/qt5-webengine/work/qtwebengine-opensource-src-5.9.5/src/3rdparty/chromium=. -pthread --target=arm-linux-gnueabihf -march=armv7-a -mfloat-abi=hard -mtune=generic-armv7-a -mfpu=vfpv3-d16 -mthumb -O2 -fno-ident -fdata-sections -ffunction-sections -g0 -fvisibility=hidden -Wheader-hygiene -Wstring-conversion -Wall -Wno-unused-variable -Wno-missing-field-initializers -Wno-unused-parameter -Wno-c++11-narrowing -Wno-covered-switch-default -Wno-deprecated-register -Wno-unneeded-internal-declaration -Wno-inconsistent-missing-override -Wno-shift-negative-value -Wno-undefined-var-template -Wno-nonportable-include-path -fno-threadsafe-statics -fvisibility-inlines-hidden -std=gnu++11 -fno-rtti -fno-exceptions -Wno-deprecated -c ../../../../qtwebengine-opensource-src-5.9.5/src/3rdparty/chromium/base/third_party/symbolize/symbolize.cc -o obj/base/third_party/symbolize/symbolize/symbolize.o
../../../../qtwebengine-opensource-src-5.9.5/src/3rdparty/chromium/base/third_party/symbolize/symbolize.cc:59:10: fatal error: 'limits' file not found
#include <limits>
         ^~~~~~~~
1 error generated.
Comment 1 mikael.urankar 2018-06-02 18:34:50 UTC
Hey, long time no see.
Can you test the patch at bug #228603?
Comment 2 mikael.urankar 2018-06-02 18:34:50 UTC
Hey, long time no see.
Can you test the patch at bug #228603?
Comment 3 Ulrich Grey 2018-06-04 15:30:15 UTC
Created attachment 193999 [details]
Successful build log
Comment 4 Ulrich Grey 2018-06-04 15:33:11 UTC
Comment on attachment 193999 [details]
Successful build log

I have applied your patch, the build was successful.
Please see the attaches poudriere build log.
It is a native build un a wandboard-quad running:
FreeBSD 12.0-CURRENT #0 r333645
Comment 5 Tobias C. Berner freebsd_committer 2018-06-04 15:36:18 UTC
I'll close this as a duplicate then.

Mfg Tobias

*** This bug has been marked as a duplicate of bug 228603 ***
Comment 6 Adriaan de Groot freebsd_committer 2018-06-04 15:43:10 UTC
I'm just going to test-build this on my Pine64 to double-check.
Comment 7 Ulrich Grey 2018-06-04 15:49:13 UTC
Created attachment 194000 [details]
Successful build log

Something went wrong.
Here ist the correct build log.
How can I edit my comment?
Comment 8 Mark Linimon freebsd_committer freebsd_triage 2018-06-04 17:41:40 UTC
(In reply to Ulrich Grey from comment #7)

Comments actually can't be edited, but we are able to figure out things anyway :-)

Are you able to build the port successfully with the latest checkin?  Otherwise I will reopen.
Comment 9 Ulrich Grey 2018-06-04 19:43:24 UTC
No, it is built using a patched portsnap generated ports tree from yesterday on 12-CURRENT. clang60 is used:

_CCVERSION_921dbbb2=FreeBSD clang version 6.0.0 (tags/RELEASE_600/final 326565) (based on LLVM 6.0.0) Target: armv7-unknown-freebsd12.0-gnueabihf
Comment 10 commit-hook freebsd_committer 2018-06-06 13:53:35 UTC
A commit references this bug:

Author: adridg
Date: Wed Jun  6 13:53:05 UTC 2018
New revision: 471843
URL: https://svnweb.freebsd.org/changeset/ports/471843

Log:
  Fix www/qt5-webengine to build on ARM

  Fix build for aarch64 and armv7. Chasing Chromium patches into Qt5-Webengine
  is a slow process. Multiple build successes have been reported with
  this patch, although I have not been able to try it myself.

  I hope I got all the attributions right.

  PR:		228603 228708
  Submitted by:	mikael.urankar@gmail.com
  Reported by:	mikael.urankar@gmail.com, usenet@ulrich-grey.de
  Obtained from:	mmel

Changes:
  head/www/qt5-webengine/files/patch-src_3rdparty_chromium_build_config_compiler_BUILD.gn
  head/www/qt5-webengine/files/patch-src_3rdparty_chromium_third__party_boringssl_src_include_openssl_cpu.h
  head/www/qt5-webengine/files/patch-src_3rdparty_chromium_v8_src_arm_cpu-arm.cc
  head/www/qt5-webengine/files/patch-src_3rdparty_chromium_v8_src_base_cpu.cc
  head/www/qt5-webengine/files/patch-src_3rdparty_chromium_v8_src_base_platform_platform-freebsd.cc
  head/www/qt5-webengine/files/patch-src_3rdparty_chromium_v8_src_libsampler_sampler.cc