Bug 229028 - mail/opendkim: Fails to build with OpenSSL 1.1
Summary: mail/opendkim: Fails to build with OpenSSL 1.1
Status: Closed DUPLICATE of bug 223568
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks: 228865
  Show dependency treegraph
 
Reported: 2018-06-14 20:17 UTC by Bernard Spil
Modified: 2018-06-15 09:37 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (freebsd-ports)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernard Spil freebsd_committer 2018-06-14 20:17:53 UTC
> checking for library containing SSL_library_init... no

During BSDCan 2018 the intention to update OpenSSL in base to 1.1.x branch was documented.

Intention is to update 12-STABLE to current 1.1.0 and subsequently update it to 1.1.1 when that is released. The intent to update OpenSSL to 1.1 in 12 has now officially been documented in Bug #228912 

Poudriere log: https://keg.brnrd.eu/data/111amd64-default-openssl110/2018-06-11_10h42m37s/logs/errors/opendkim-2.10.3_7.log
Comment 1 Markus Kohlmeyer 2018-06-15 00:28:05 UTC
Upstream fix: https://github.com/trusteddomainproject/OpenDKIM/commit/3deafe9a2b43a41ae740836b8c689e132424e1ac

It seems that version 2.11.0 will be released this year.

BTW: Upstream changed name from OpenDKIM Project to TrustedDomain Project and also moved from SourceForge to GitHub.
Comment 2 Bernard Spil freebsd_committer 2018-06-15 08:37:13 UTC
Hi Markus,

Can you create an svn diff for that and attach it? (don't forget to do QA checks/builds for it). I can commit the change but am way too busy updating OpenSSL in base to piece this together.

Thanks! Bernard.
Comment 3 Bernard Spil freebsd_committer 2018-06-15 09:37:44 UTC

*** This bug has been marked as a duplicate of bug 223568 ***