Bug 229732 - dns/knot2: unbreak on aarch64
Summary: dns/knot2: unbreak on aarch64
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm64 Any
: --- Affects Only Me
Assignee: Mark Linimon
URL:
Keywords:
Depends on:
Blocks: 201763
  Show dependency treegraph
 
Reported: 2018-07-12 13:34 UTC by Greg V
Modified: 2018-11-01 15:12 UTC (History)
5 users (show)

See Also:
bugzilla: maintainer-feedback? (freebsd)


Attachments
knot2.patch (454 bytes, patch)
2018-07-12 13:34 UTC, Greg V
no flags Details | Diff
svn diff to also add @dirs to plist (932 bytes, patch)
2018-07-15 15:02 UTC, Vidar Karlsen
vidar: maintainer-approval? (greg)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Greg V 2018-07-12 13:34:38 UTC
Created attachment 195083 [details]
knot2.patch

This is literally the strangest portability issue. For some reason, the build process mkdirs /var/db/knot and /var/run/knot on amd64, but doesn't on aarch64. o_0
Comment 1 Walter Schwarzenfeld freebsd_triage 2018-07-15 14:29:27 UTC
(In reply to Greg V from comment #0)
No, same problem on amd64. It is the question if we patch the Makefile, like you did or it is pkg-plist
error and we make a patch for pkg-plist?
Comment 2 Vidar Karlsen 2018-07-15 15:02:57 UTC
Created attachment 195152 [details]
svn diff to also add @dirs to plist

I ran poudriere testport on amd64 and armv6, it didn't create those directories there either.
Running the same tests after applying your patch gives me plist errors.

Attached is a patch that:
- Adds the ${MKDIR} line to Makefile like your original patch
- Adds /var/db/knot and /var/run/knot to pkg-plist
- Bumps PORTREVISION
Comment 3 Leo Vandewoestijne 2018-08-07 11:16:34 UTC
Hello all,

I merged the patch of Vidar Karlsen into the one that brings Knot to 2.7.0
See PR 230433

My own tests went well, but please let me know if that solved the problem.

Leo.
Comment 4 Leo Vandewoestijne 2018-08-23 11:41:13 UTC
Hello all,

I merged the initial patch of Greg V and the additional patch of Vidar Karlsen into the one that should bring dns/knot2 from 2.6.8 to the newer 2.7.1
That's PR 230841

Again my own tests went well (i386 and amd64 only, and avoiding the combi 11.2/i386).
Please let me know if this solved the problem.

Leo.
Comment 5 Mark Linimon freebsd_committer freebsd_triage 2018-11-01 15:12:49 UTC
Obsoleted by 232284.