Bug 231733 - [maintainer update] devel/lua-stdlib-normalize: update to 2.0.2
Summary: [maintainer update] devel/lua-stdlib-normalize: update to 2.0.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Steve Wills
URL:
Keywords:
: 229891 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-09-26 11:08 UTC by Kan Sasaki
Modified: 2019-08-26 18:05 UTC (History)
2 users (show)

See Also:
sasaki: maintainer-feedback+


Attachments
lua-stdlib-normalize.patch (2.86 KB, patch)
2018-09-26 11:08 UTC, Kan Sasaki
sasaki: maintainer-approval+
Details | Diff
Alternative (2.82 KB, patch)
2018-09-27 02:16 UTC, Nathan
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kan Sasaki 2018-09-26 11:08:54 UTC
Created attachment 197507 [details]
lua-stdlib-normalize.patch

Update to 2.0.2 including changes I submitted in PR229891.

Documents are moved under doc/lua${LUA_VER_STR}/${PORTNAME} like lang/lua53.
Comment 1 Nathan 2018-09-27 02:16:16 UTC
Created attachment 197540 [details]
Alternative

Attaching this here, so you can see an alternative/easier way to do the DOCS portion
Comment 2 Nathan 2018-09-27 02:17:07 UTC
(In reply to Nathan from comment #1)
Also note, the removal of DOCS in plist, as with this method, no need of having it in the plist
Comment 3 Nathan 2018-09-27 03:37:11 UTC
(In reply to Nathan from comment #2)
Also, if you do it the way I did it, remove pkg-plist and put the remaining files in Makefile 
PLIST=
Comment 4 Kan Sasaki 2018-09-27 07:13:50 UTC
(In reply to Nathan from comment #3)
Thanks. But the Porter Handbook shows maintainers should use static package lists:

https://www.freebsd.org/doc/en/books/porters-handbook/plist-dynamic.html

I think this ports is simple, but which is better at the moment?
Comment 5 Nathan 2018-09-28 23:14:23 UTC
(In reply to Kan Sasaki from comment #4)

The alternative way I posted is how I do my ports. I try to make mine as simple/small as possible
Comment 6 Kan Sasaki 2018-10-01 07:24:22 UTC
(In reply to Nathan from comment #5)
I'll follow the handbook. Thank you, though.
Comment 7 Kan Sasaki 2018-10-02 13:45:58 UTC
Comment on attachment 197540 [details]
Alternative

I'll follow the handbook.
Comment 8 commit-hook freebsd_committer 2018-10-06 18:16:14 UTC
A commit references this bug:

Author: swills
Date: Sat Oct  6 18:15:42 UTC 2018
New revision: 481384
URL: https://svnweb.freebsd.org/changeset/ports/481384

Log:
  devel/lua-stdlib-normalize: update to 2.0.2

  PR:		231733
  Submitted by:	Kan Sasaki <sasaki@fcc.ad.jp> (maintainer)

Changes:
  head/devel/lua-stdlib-normalize/Makefile
  head/devel/lua-stdlib-normalize/distinfo
  head/devel/lua-stdlib-normalize/pkg-plist
Comment 9 Steve Wills freebsd_committer 2018-10-06 18:16:48 UTC
Committed, thanks!
Comment 10 Walter Schwarzenfeld freebsd_triage 2019-08-26 18:05:03 UTC
*** Bug 229891 has been marked as a duplicate of this bug. ***