Bug 233774 - ports-mgmt/portlint: doesn't support LICENSE with multiple values
Summary: ports-mgmt/portlint: doesn't support LICENSE with multiple values
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Joe Marcus Clarke
URL:
Keywords:
: 234820 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-12-04 13:27 UTC by Larry Rosenman
Modified: 2019-01-22 16:22 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (marcus)


Attachments
Patch (490 bytes, patch)
2019-01-10 17:38 UTC, Dmitry Marakasov
no flags Details | Diff
Patch (494 bytes, patch)
2019-01-10 17:41 UTC, Dmitry Marakasov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Larry Rosenman freebsd_committer 2018-12-04 13:27:51 UTC
portlint gives me a FATAL error when the following are included:

LICENSE=	LGPL21 MIT
LICENSE_COMB=	dual
LICENSE_FILE_LGPL21=	${WRKSRC}/COPYING.LGPL
LICENSE_FILE_MIT=	${WRKSRC}/COPYING.MIT

The error reported is:
FATAL: Makefile: license specified is LGPL21 MIT, but LICENSE_FILE specified is for LGPL21.

Can this be fixed?

Thanks!
Comment 1 Mateusz Piotrowski freebsd_committer 2019-01-10 13:34:23 UTC
*** Bug 234820 has been marked as a duplicate of this bug. ***
Comment 2 Dmitry Marakasov freebsd_committer 2019-01-10 17:38:05 UTC
Created attachment 200993 [details]
Patch

How about this fix?
Comment 3 Joe Marcus Clarke freebsd_committer 2019-01-10 17:40:43 UTC
Thanks.  Patch looks good to me.  Committing this to my repo pending the next release.
Comment 4 Dmitry Marakasov freebsd_committer 2019-01-10 17:41:01 UTC
Created attachment 200994 [details]
Patch

Or, rather, this one.
Comment 5 Dmitry Marakasov freebsd_committer 2019-01-22 15:07:34 UTC
What's holding this up?
Comment 6 commit-hook freebsd_committer 2019-01-22 16:19:27 UTC
A commit references this bug:

Author: marcus
Date: Tue Jan 22 16:19:07 UTC 2019
New revision: 490959
URL: https://svnweb.freebsd.org/changeset/ports/490959

Log:
  Update to 2.18.8

  * Handle multiple licenses [1]
  * Warn about leading and trailing whitespace in pkg-descr [2]

  PR:		233774 [1]
  		235070 [2]
  Submitted by:	amdmi3 [1]
  		swills [2]

Changes:
  head/ports-mgmt/portlint/Makefile
  head/ports-mgmt/portlint/src/portlint.pl
Comment 7 Joe Marcus Clarke freebsd_committer 2019-01-22 16:22:32 UTC
Committed to 2.18.8.