Bug 234820 - ports-mgmt/portlint: incorrect LICENSE related errors
Summary: ports-mgmt/portlint: incorrect LICENSE related errors
Status: Closed DUPLICATE of bug 233774
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Joe Marcus Clarke
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-10 13:28 UTC by Dmitry Marakasov
Modified: 2019-01-10 13:34 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (marcus)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Marakasov freebsd_committer 2019-01-10 13:28:35 UTC
For instance, /usr/ports/x11/libexo:

LICENSE=        GPLv2 LGPL21
LICENSE_COMB=   multi
LICENSE_FILE_GPLv2=     ${WRKSRC}/COPYING
LICENSE_FILE_LGPL21=    ${WRKSRC}/COPYING.LIB

FATAL: Makefile: license specified is GPLv2 LGPL21, but LICENSE_FILE specified is for GPLv2.
Comment 1 Mateusz Piotrowski freebsd_committer 2019-01-10 13:34:23 UTC

*** This bug has been marked as a duplicate of bug 233774 ***