Bug 236514 - lang/julia06: remove the ability to use base llvm40
Summary: lang/julia06: remove the ability to use base llvm40
Status: Closed DUPLICATE of bug 235872
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks: 231286
  Show dependency treegraph
 
Reported: 2019-03-13 19:14 UTC by Brooks Davis
Modified: 2019-03-14 15:26 UTC (History)
1 user (show)

See Also:
iblis: maintainer-feedback+


Attachments
Remove ability to use devel/llvm40 (1.52 KB, patch)
2019-03-13 19:14 UTC, Brooks Davis
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brooks Davis freebsd_committer 2019-03-13 19:14:09 UTC
Created attachment 202846 [details]
Remove ability to use devel/llvm40

Julia 0.6 is unable to work with any modern LLVM version and all possible LLVM options are on track for removal.  The other remaining dependencies on llvm40 are upgradable so I'd like to remove the external version rather than dragging it around for a single port.
Comment 1 Iblis Lin 2019-03-14 02:01:51 UTC
It's already removed in this patch https://bugs.freebsd.org/bugzilla/attachment.cgi?id=202173&action=diff#b/lang/julia06/Makefile_sec2

Let's wait for PR #202173?
Comment 2 Brooks Davis freebsd_committer 2019-03-14 15:26:50 UTC
PR 235872 includes this change and more.

*** This bug has been marked as a duplicate of bug 235872 ***