Bug 237384 - www/redmine: Remove bundler dependency pin (Fails to start due to > 2.0.0)
Summary: www/redmine: Remove bundler dependency pin (Fails to start due to > 2.0.0)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ruby mailing list
URL:
Keywords: easy
Depends on:
Blocks:
 
Reported: 2019-04-19 11:28 UTC by Koichiro Iwao
Modified: 2019-04-22 09:07 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (ruby)
meta: merge-quarterly-


Attachments
patch-redmine (1.78 KB, patch)
2019-04-19 11:28 UTC, Koichiro Iwao
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Koichiro Iwao freebsd_committer 2019-04-19 11:28:29 UTC
Created attachment 203797 [details]
patch-redmine

Without this patch, redmine doesn't start due to dependency mismatch.
 

# cd /usr/ports/www/redmine
# puma 
Puma starting in single mode...                 
* Version 3.12.0 (ruby 2.5.5-p157), codename: Llamas in Pajamas
* Min threads: 0, max threads: 16
* Environment: development                                     
Bundler could not find compatible versions for gem "bundler":
  In Gemfile:                                                                                                          
    bundler (>= 1.5.0, < 2.0.0)  
                                             
  Current Bundler version:                                                                                              
    bundler (2.0.1)                                                                                                     
This Gemfile requires a different version of Bundler.
Perhaps you need to update Bundler by running `gem install bundler`?                                                   
                                                                                                                        
Could not find gem 'bundler (>= 1.5.0, < 2.0.0)' in any of the relevant sources:                                       
  the local ruby installation                                                                                          
! Unable to load application: SystemExit: exit
Comment 1 Koichiro Iwao freebsd_committer 2019-04-19 11:34:08 UTC
Works properly if this patch applied. Also confirmed redmine actually works fine.

# cd /usr/local/www/redmine
# puma
Puma starting in single mode...
* Version 3.12.0 (ruby 2.5.5-p157), codename: Llamas in Pajamas
* Min threads: 0, max threads: 16
* Environment: development
* Listening on tcp://0.0.0.0:9292
Use Ctrl-C to stop
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2019-04-19 11:50:04 UTC
Just for reference, the current rubygem-bundler port is at 1.17.3,1. Where did bundler 2.0.1 come from in this installation?
Comment 3 Matthias Fechner freebsd_committer 2019-04-19 12:15:05 UTC
All PRs you created are looking fine for me.
If you think you do not break anything, please continue to commit them all.
Comment 4 Koichiro Iwao freebsd_committer 2019-04-20 08:30:38 UTC
(In reply to Kubilay Kocak from comment #2)

Bundler 2.0.1 is suggested at bug 235796. Not to break www/redmine after updating sysutils/rubygem-bundler to 2.0.1, I'm fixing this beforehand.

MFH is not needed because sysutils/rubygem-bundler in 2019Q2 branch stays on 1.17.3.
Comment 5 Koichiro Iwao freebsd_committer 2019-04-20 08:51:28 UTC
bundler in 2019Q2 branch is acrually 1.17.1.
Comment 6 commit-hook freebsd_committer 2019-04-20 08:52:42 UTC
A commit references this bug:

Author: meta
Date: Sat Apr 20 08:52:12 UTC 2019
New revision: 499430
URL: https://svnweb.freebsd.org/changeset/ports/499430

Log:
  www/redmine: Remove bundler dependency pin on bundler < 2.0

  To adapt upcoming update of sysutils/rubygem-bundler to 2.0.1.

  PR:		237384
  Submitted by:	meta (myself)
  Reviewed by:	mfechner

Changes:
  head/www/redmine/Makefile
  head/www/redmine/files/patch-Gemfile
Comment 7 Koichiro Iwao freebsd_committer 2019-04-20 08:53:11 UTC
Committed, thanks for your help!