Bug 235796 - sysutils/rubygem-bundler: Update to 2.0.1
Summary: sysutils/rubygem-bundler: Update to 2.0.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Koichiro Iwao
URL:
Keywords: patch
Depends on: 237379 237460
Blocks: 234509 235826 236908
  Show dependency treegraph
 
Reported: 2019-02-17 05:59 UTC by Yasuhiro KIMURA
Modified: 2019-05-07 05:50 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (ruby)


Attachments
patch file (786 bytes, patch)
2019-02-17 05:59 UTC, Yasuhiro KIMURA
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yasuhiro KIMURA 2019-02-17 05:59:05 UTC
Created attachment 202084 [details]
patch file

Update to 2.0.1.
Comment 1 Koichiro Iwao freebsd_committer 2019-04-03 08:00:05 UTC
QA looks good to me.
Comment 2 Koichiro Iwao freebsd_committer 2019-04-03 08:07:40 UTC
Just for the record, bundler 2 requires rubygems 3.0.0 at minimum.
The current version of devel/ruby-gems is 3.0.3. Ready to commit.
Comment 3 commit-hook freebsd_committer 2019-04-03 08:24:58 UTC
A commit references this bug:

Author: meta
Date: Wed Apr  3 08:24:13 UTC 2019
New revision: 497674
URL: https://svnweb.freebsd.org/changeset/ports/497674

Log:
  sysutils/rubygem-bundler: Update to 2.0.1

  PR:		235796
  Submitted by:	Yasuhiro KIMURA <yasu@utahime.org>

Changes:
  head/sysutils/rubygem-bundler/Makefile
  head/sysutils/rubygem-bundler/distinfo
Comment 4 Koichiro Iwao freebsd_committer 2019-04-03 08:26:50 UTC
Committed, thanks!
Comment 5 commit-hook freebsd_committer 2019-04-03 14:46:10 UTC
A commit references this bug:

Author: meta
Date: Wed Apr  3 14:45:32 UTC 2019
New revision: 497732
URL: https://svnweb.freebsd.org/changeset/ports/497732

Log:
  Revert r497674, it breaks some consumers

  PR:		235796
  Reported by:	mfechner

Changes:
  head/sysutils/rubygem-bundler/Makefile
  head/sysutils/rubygem-bundler/distinfo
Comment 6 Koichiro Iwao freebsd_committer 2019-04-04 08:51:24 UTC
Reverted due to breakage on some consumers.  Need to keep 1.17 series as sysutils/rubygem-bundler117. And then I'll update rubygem-bundler again.
Comment 7 Koichiro Iwao freebsd_committer 2019-04-16 06:33:12 UTC
mfechner, you recent fix devel/gitaly and others seems to fix www/redmine and www/gitlab-ce with Bundler 2. Is Bundler 1 series still needed?
Comment 8 Matthias Fechner freebsd_committer 2019-04-17 04:58:57 UTC
I have not tested it with the new version but in theory gitlab-ce should build.
If it builds for you, it should normally work without any issues.
Comment 9 Matthias Fechner freebsd_committer 2019-04-19 12:15:40 UTC
All PRs you created are looking fine for me.
If you think you do not break anything, please continue to commit them all.
Comment 10 Koichiro Iwao freebsd_committer 2019-04-23 03:05:32 UTC
After I test all ports depends on bundler. Some more ports need to loosen bundler version pinning like bug 237384. I'm still not sure just looseing bundler version works well.

$ grep bundler INDEX-12| cut -d\| -f2 | sed -e 's|^/usr/ports/||' 


$ for p in $(grep bundler INDEX-12| cut -d\| -f2 | sed -e 's|^/usr/ports/||'); do sudo poudriere testport -j 12amd64 -p custom $p; read; done

These ports needs to be patched.

devel/rubygem-tty: bug 237460
lang/rubinius: wip
Comment 11 Koichiro Iwao freebsd_committer 2019-05-03 10:59:36 UTC
It turned out build failure of lang/rubinius is not caused by bundler.
Comment 12 commit-hook freebsd_committer 2019-05-07 04:31:29 UTC
A commit references this bug:

Author: meta
Date: Tue May  7 04:31:17 UTC 2019
New revision: 500949
URL: https://svnweb.freebsd.org/changeset/ports/500949

Log:
  sysutils/rubygem-bundler: Update to 2.0.1

  It's time to introduce Bundler 2 again.

  PR:		235796
  Reviewed by:	mfechner
  Approved by:	mfechner

Changes:
  head/sysutils/rubygem-bundler/Makefile
  head/sysutils/rubygem-bundler/distinfo