Bug 239939 - graphics/mesa-dri: switch to default python version for build
Summary: graphics/mesa-dri: switch to default python version for build
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-x11 mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-18 13:09 UTC by VVD
Modified: 2019-09-21 15:34 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments
Switch to default python version for build (349 bytes, patch)
2019-08-18 13:09 UTC, VVD
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description VVD 2019-08-18 13:09:26 UTC
Created attachment 206658 [details]
Switch to default python version for build

Tested with python 3.6 and 3.7 on 12.0 amd64 and i386.
Comment 1 Dimitry Andric freebsd_committer 2019-09-17 17:16:21 UTC
So, is this supposed to solve errors like:

===>   mesa-libs-18.3.2_1 depends on file: /usr/local/bin/python2.7 - found
===>   mesa-libs-18.3.2_1 depends on package: llvm80>=3.9.0_4 - not found
===>  llvm80-8.0.1_3 needs Python 3.6 at least, but 2.7 was specified.

E.g. somehow mesa is forcing the internal python version to 2.7, then the sub-make for building llvm80 inherits that, and dies.
Comment 2 Dimitry Andric freebsd_committer 2019-09-17 17:18:52 UTC
Right, I should just have tried your patch.  This works for me!

[...]
===>   mesa-libs-18.3.2_1 depends on file: /usr/local/libdata/pkgconfig/pthread-stubs.pc - found
===>   mesa-libs-18.3.2_1 depends on executable: bison - found
===>   mesa-libs-18.3.2_1 depends on executable: msgfmt - found
===>   mesa-libs-18.3.2_1 depends on executable: gmake - found
===>   mesa-libs-18.3.2_1 depends on package: pkgconf>=1.3.0_1 - found
===>   mesa-libs-18.3.2_1 depends on file: /usr/local/bin/python3.7 - found
===>   mesa-libs-18.3.2_1 depends on package: llvm80>=3.9.0_4 - not found
===>  Building for llvm80-8.0.1_3
Comment 3 Niclas Zeising freebsd_committer 2019-09-17 18:38:04 UTC
There are still several python scripts in the sources that look for something to do with python2.  I have to look into the details of if they are needed and/or executed.  The documentation only says 2.7 is needed with scons, but I don't know about what's needed with autotools.
Comment 4 VVD 2019-09-18 00:01:32 UTC
(In reply to Niclas Zeising from comment #3)
I removed python27 and mesa rebuild fine.