Bug 243208 - www/firefox build error error: variable has incomplete type 'cap_rights_t' (aka 'cap_rights') cap_rights_t rights;
Summary: www/firefox build error error: variable has incomplete type 'cap_rights_t' (a...
Status: Closed DUPLICATE of bug 243213
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-gecko (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-09 09:56 UTC by nick.rozhkov
Modified: 2020-01-14 01:29 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nick.rozhkov 2020-01-09 09:56:46 UTC
Port build configuration
OPTIONS_FILE_SET+=CANBERRA
OPTIONS_FILE_SET+=DBUS
OPTIONS_FILE_UNSET+=DEBUG
OPTIONS_FILE_SET+=FFMPEG
OPTIONS_FILE_SET+=GCONF
OPTIONS_FILE_SET+=LIBPROXY
OPTIONS_FILE_SET+=OPTIMIZED_CFLAGS
OPTIONS_FILE_SET+=PROFILE
OPTIONS_FILE_UNSET+=TEST
OPTIONS_FILE_SET+=ALSA
OPTIONS_FILE_SET+=JACK
OPTIONS_FILE_SET+=PULSEAUDIO
OPTIONS_FILE_UNSET+=SNDIO

Error log
ipc/chromium/Unified_cpp_ipc_chromium2.o
gmake[5]: Leaving directory '/usr/ports/www/firefox/work/.build/extensions/auth'
/usr/local/bin/clang++90 -o BackgroundParentImpl.o -c  -I/usr/ports/www/firefox/work/.build/dist/stl_wrappers -I/usr/ports/www/firefox/work/.build/dist/system_wrappers -include /usr/ports/www/firefox/work/firefox-72.0.1/config/gcc_hidden.h -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-strong -DNDEBUG=1 -DTRIMMED=1 -DHAVE_UINT64_T -DWEBRTC_POSIX -DWEBRTC_BUILD_LIBEVENT -DWEBRTC_BSD -DOS_POSIX=1 -DOS_FREEBSD=1 -DOS_BSD=1 '-DMOZ_CHILD_PROCESS_NAME="plugin-container"' '-DMOZ_CHILD_PROCESS_BUNDLE="plugin-container.app/Contents/MacOS/"' -DSTATIC_EXPORTABLE_JS_API -DMOZ_HAS_MOZGLUE -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -I/usr/ports/www/firefox/work/firefox-72.0.1/ipc/glue -I/usr/ports/www/firefox/work/.build/ipc/glue -I/usr/ports/www/firefox/work/firefox-72.0.1/caps -I/usr/ports/www/firefox/work/firefox-72.0.1/dom/broadcastchannel -I/usr/ports/www/firefox/work/firefox-72.0.1/dom/indexedDB -I/usr/ports/www/firefox/work/firefox-72.0.1/dom/storage -I/usr/ports/www/firefox/work/firefox-72.0.1/media/webrtc/trunk -I/usr/ports/www/firefox/work/firefox-72.0.1/media/webrtc/trunk/webrtc -I/usr/ports/www/firefox/work/firefox-72.0.1/xpcom/build -I/usr/ports/www/firefox/work/firefox-72.0.1/dom/ipc -I/usr/ports/www/firefox/work/firefox-72.0.1/toolkit/crashreporter -I/usr/ports/www/firefox/work/firefox-72.0.1/toolkit/xre -I/usr/ports/www/firefox/work/firefox-72.0.1/xpcom/base -I/usr/ports/www/firefox/work/firefox-72.0.1/xpcom/threads -I/usr/ports/www/firefox/work/.build/ipc/ipdl/_ipdlheaders -I/usr/ports/www/firefox/work/firefox-72.0.1/ipc/chromium/src -I/usr/ports/www/firefox/work/firefox-72.0.1/ipc/glue -I/usr/ports/www/firefox/work/.build/dist/include -I/usr/local/include/nspr -I/usr/local/include/nss -I/usr/local/include/nss/nss -I/usr/ports/www/firefox/work/.build/dist/include/nss -I/usr/local/include -I/usr/local/include -I/usr/local/include/pixman-1 -fPIC -DMOZILLA_CLIENT -include /usr/ports/www/firefox/work/.build/mozilla-config.h -Qunused-arguments -DLIBICONV_PLUG -isystem /usr/local/include -Qunused-arguments -Wall -Wbitfield-enum-conversion -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wshadow-field-in-constructor-modified -Wsign-compare -Wtype-limits -Wunreachable-code -Wunreachable-code-return -Wwrite-strings -Wno-invalid-offsetof -Wclass-varargs -Wfloat-overflow-conversion -Wfloat-zero-conversion -Wloop-analysis -Wc++1z-compat -Wc++2a-compat -Wcomma -Wimplicit-fallthrough -Wstring-conversion -Wtautological-overlap-compare -Wtautological-unsigned-enum-zero-compare -Wtautological-unsigned-zero-compare -Wno-error=tautological-type-limit-compare -Wno-inline-new-delete -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wno-error=backend-plugin -Wno-error=return-std-move -Wno-error=atomic-alignment -Wformat -Wformat-security -Wno-gnu-zero-variadic-macro-arguments -Wno-unknown-warning-option -Wno-return-type-c-linkage -fno-sized-deallocation -fno-aligned-new -O2 -pipe -march=native -O3 -DLIBICONV_PLUG -fstack-protector-strong -isystem /usr/local/include -fno-strict-aliasing -DLIBICONV_PLUG -isystem /usr/local/include -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -pipe -I/usr/local/include -O2 -O3 -fno-omit-frame-pointer -funwind-tables -Wno-error=shadow -Wno-shadow  -MD -MP -MF .deps/BackgroundParentImpl.o.pp   /usr/ports/www/firefox/work/firefox-72.0.1/ipc/glue/BackgroundParentImpl.cpp
ipc/glue/FileDescriptorSetChild.o
In file included from Unified_cpp_ipc_chromium0.cpp:137:
/usr/ports/www/firefox/work/firefox-72.0.1/ipc/chromium/src/base/shared_memory_posix.cc:282:16: error: variable has incomplete type 'cap_rights_t' (aka 'cap_rights')
  cap_rights_t rights;
               ^
/usr/include/sys/types.h:249:8: note: forward declaration of 'cap_rights'
struct cap_rights;
       ^
In file included from Unified_cpp_ipc_chromium0.cpp:137:
/usr/ports/www/firefox/work/firefox-72.0.1/ipc/chromium/src/base/shared_memory_posix.cc:283:28: error: use of undeclared identifier 'CAP_MMAP_R'
  cap_rights_init(&rights, CAP_MMAP_R);
                           ^
2 errors generated.
gmake[5]: *** [/usr/ports/www/firefox/work/firefox-72.0.1/config/rules.mk:806: Unified_cpp_ipc_chromium0.o] Error 1
gmake[5]: *** Waiting for unfinished jobs....
Comment 1 rozhuk.im 2020-01-09 14:42:42 UTC
Look like fixed, after www/firefox/files/patch-bug1550891 was updated.
Comment 2 nick.rozhkov 2020-01-09 16:46:39 UTC
Seems like fixed and for me too
Comment 3 rozhuk.im 2020-01-13 14:42:26 UTC
If fixed - mark BUG as closed - FIXED.
Comment 4 Jan Beich freebsd_committer 2020-01-13 15:02:19 UTC

*** This bug has been marked as a duplicate of bug 243213 ***
Comment 5 rozhuk.im 2020-01-13 17:29:36 UTC
This was not duplicate: this build error, and mine is run time crash.
Comment 6 Jan Beich freebsd_committer 2020-01-13 21:58:14 UTC
Why do you need more than one bug? Pick either this one or bug 243320.
Comment 7 rozhuk.im 2020-01-14 01:29:35 UTC
(In reply to Jan Beich from comment #6)

This bug already fixed :)