Bug 244162 - graphics/gmic-qt: Flavorize the port to support all 3 variants: "gimp", "krita", standalone
Summary: graphics/gmic-qt: Flavorize the port to support all 3 variants: "gimp", "krit...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Yuri Victorovich
URL: https://reviews.freebsd.org/D23994
Keywords:
: 244161 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-02-16 10:50 UTC by Yuri Victorovich
Modified: 2020-09-05 19:33 UTC (History)
2 users (show)

See Also:
tcberner: maintainer-feedback+


Attachments
suggested patch (2.88 KB, patch)
2020-02-29 22:13 UTC, Yuri Victorovich
no flags Details | Diff
suggested patch (3.52 KB, patch)
2020-02-29 23:58 UTC, Yuri Victorovich
tcberner: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2020-02-16 10:50:06 UTC
The GMIC_QT_HOST can be set alternatively to "gimp", "krita" or "none" ("none" would build a standalone version).

Currently users who wish to use gmic with gimp can't do so.

Please flavorize the port to have all three choices available with different flavors.
Comment 1 Tobias C. Berner freebsd_committer 2020-02-16 10:54:11 UTC
Moin moin

Sure, sounds doable. I'll look into it.


mfg Tobias
Comment 2 Tobias C. Berner freebsd_committer 2020-02-17 04:38:28 UTC
*** Bug 244161 has been marked as a duplicate of this bug. ***
Comment 3 lumiwa 2020-02-28 20:57:36 UTC
I did solve my problem with gmic-qt. Because I do not krita I just change "krita" with "gimp" and also in pkg-list. It works without problems :). I do not know why I didn't do this year ago...

Thank you anywhere.
Comment 4 Yuri Victorovich freebsd_committer 2020-02-29 22:13:17 UTC
Created attachment 212054 [details]
suggested patch

The attached patch creates 3 flavors corresponding to the cmake variable GMIC_QT_HOST that this software depends on:
* none: builds a standalone application (default flavor)
* krita: builds a Krita plugin
* gimp: builds a Gimp plugin

The flavors can't be installed at the same time pending resolution of https://github.com/c-koi/gmic-qt/issues/83
Comment 5 Tobias C. Berner freebsd_committer 2020-02-29 23:28:07 UTC
Moin moin 

Thanks, you should also update the run-depends in graphics/krita.
I'll try to test your patch as soon as possible.


mfg Tobias
Comment 6 Yuri Victorovich freebsd_committer 2020-02-29 23:58:49 UTC
Created attachment 212060 [details]
suggested patch

Patch update:
* Add the change in graphics/krita
* Add the CONFLICTS_INSTALL line.
Comment 7 Tobias C. Berner freebsd_committer 2020-03-07 07:12:30 UTC
Comment on attachment 212060 [details]
suggested patch

Thanks :) -- Ship it!


mfg Tobias
Comment 8 Yuri Victorovich freebsd_committer 2020-03-07 16:16:11 UTC
(In reply to Tobias C. Berner from comment #7)

Thanks!

Would you commit it, or should I commit it?


Yuri
Comment 9 Tobias C. Berner freebsd_committer 2020-03-07 16:21:14 UTC
(In reply to Yuri Victorovich from comment #8)
You did the work, so you should get the glory :)
Comment 10 lumiwa 2020-04-03 10:32:26 UTC
Thank you very much for the patch. It works and I hope it will come once in the ports too.
Comment 11 Yuri Victorovich freebsd_committer 2020-09-05 19:33:31 UTC
Flavors committed.
Comment 12 commit-hook freebsd_committer 2020-09-05 19:33:41 UTC
A commit references this bug:

Author: yuri
Date: Sat Sep  5 19:33:17 UTC 2020
New revision: 547673
URL: https://svnweb.freebsd.org/changeset/ports/547673

Log:
  graphics/gmic-qt: Flavorize the port to support all 3 variants: "gimp", "krita", standalone

  PR:		244162
  Approved by:	kde
  Differential Revision:	D23994

Changes:
  head/graphics/gmic-qt/Makefile
  head/graphics/gmic-qt/distinfo
  head/graphics/gmic-qt/pkg-plist