Bug 245394 - multimedia/obs-studio: instructions for enabling local recording
Summary: multimedia/obs-studio: instructions for enabling local recording
Status: Closed DUPLICATE of bug 245299
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Yuri Victorovich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-06 11:36 UTC by Daniel Ebdrup Jensen
Modified: 2020-04-06 18:59 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (yuri)


Attachments
A patch that adds a message describing how to fix local recording. (402 bytes, patch)
2020-04-06 11:36 UTC, Daniel Ebdrup Jensen
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Ebdrup Jensen freebsd_committer 2020-04-06 11:36:53 UTC
Created attachment 213123 [details]
A patch that adds a message describing how to fix local recording.

Because it seems like obs-studio (specifically, obs-ffmpeg-mux) is expecting /bin/sh to be /bin/bash and uses file descriptors for obs-ffmpeg-mux, "sh: permission denied" can be seen in the log file, and local recording doesn't work.
This patch adds a message for when obs-studio is installed, so that people will know where to fix it so that local recording works on FreeBSD again.

This issue pertains to bug 245299 which seems to have cropped up again, and should hopefully fix it for good.
Comment 1 Yuri Victorovich freebsd_committer 2020-04-06 16:27:05 UTC
(In reply to Daniel Ebdrup Jensen from comment #0)

Could you please add steps to reproduce the problem?

Thanks,
Yuri
Comment 2 Yuri Victorovich freebsd_committer 2020-04-06 16:39:44 UTC
On my system it records in the "Simple" mode without a problem:

info: ---------------------------------
info: [x264 encoder: 'simple_h264_stream'] preset: veryfast
info: [x264 encoder: 'simple_h264_stream'] settings:
	rate_control: CBR
	bitrate:      2500
	buffer size:  2500
	crf:          0
	fps_num:      60
	fps_den:      1
	width:        1148
	height:       646
	keyint:       250

info: libfdk_aac encoder created
info: libfdk_aac bitrate: 160, channels: 2
info: ==== Recording Start ===============================================
info: [ffmpeg muxer: 'simple_file_output'] Writing file '/home/yuri/2020-04-06 09-37-02.mkv'...
[matroska @ 0x80416c000] Using AVStream.codec to pass codec parameters to muxers is deprecated, use AVStream.codecpar instead.
[matroska @ 0x80416c000] Using AVStream.codec to pass codec parameters to muxers is deprecated, use AVStream.codecpar instead.
info: [ffmpeg muxer: 'simple_file_output'] Output of file '/home/yuri/2020-04-06 09-37-02.mkv' stopped
info: Output 'simple_file_output': stopping
info: Output 'simple_file_output': Total frames output: 1083
info: Output 'simple_file_output': Total drawn frames: 879 (1109 attempted)
info: Output 'simple_file_output': Number of lagged frames due to rendering lag/stalls: 230 (20.7%)
info: ==== Recording Stop ================================================
info: libfdk_aac encoder destroyed
info: ==== Shutting down ==================================================
Comment 3 Ed Maste freebsd_committer 2020-04-06 17:56:10 UTC
With obs-studio-25.0.1 when I click "Start Recording" (with all settings left at out-of-the-box defaults) I get:

info: ---------------------------------
info: [x264 encoder: 'simple_h264_stream'] preset: veryfast
info: [x264 encoder: 'simple_h264_stream'] settings:
        rate_control: CBR
        bitrate:      2500
        buffer size:  2500
        crf:          0
        fps_num:      30
        fps_den:      1
        width:        1280
        height:       720
        keyint:       60

info: libfdk_aac encoder created
info: libfdk_aac bitrate: 128, channels: 2
info: ==== Recording Start ===============================================
info: [ffmpeg muxer: 'simple_file_output'] Writing file '/home/emaste/2020-04-06 13-54-35.mkv'...
sh: : Permission denied
warning: [ffmpeg muxer: 'simple_file_output'] os_process_pipe_write for packet data failed
info: [ffmpeg muxer: 'simple_file_output'] Output of file '/home/emaste/2020-04-06 13-54-35.mkv' stopped
info: Output 'simple_file_output': stopping
info: Output 'simple_file_output': Total frames output: 4
info: Output 'simple_file_output': Total drawn frames: 31
info: ==== Recording Stop ================================================
info: libfdk_aac encoder destroyed

and the GUI says "An unspecified error occurred while recording."
Comment 4 Yuri Victorovich freebsd_committer 2020-04-06 18:08:33 UTC
(In reply to Ed Maste from comment #3)

obs-studio-25.0.1 is outdated. Could you please try it with the current obs-studio-25.0.4?

Thanks,
Yuri
Comment 5 Yuri Victorovich freebsd_committer 2020-04-06 18:39:16 UTC
Need feedback: confirmation that the failure occurs with the version 25.0.4

If the problem exists in 25.0.4, please also attach the kernel syscall log fragment showing the failing system call. I can't reproduce the failure on my system.
Comment 6 Li-Wen Hsu freebsd_committer 2020-04-06 18:57:21 UTC
(In reply to Yuri Victorovich from comment #5)
I've tested with 25.0.4, it works fine.
The issue was fixed by bug245299 and bug245403.
Comment 7 Yuri Victorovich freebsd_committer 2020-04-06 18:59:17 UTC

*** This bug has been marked as a duplicate of bug 245299 ***