Bug 251236 - cad/cura bug in 4.7 causes slowdowns in circular perimeters; fixed in 4.8
Summary: cad/cura bug in 4.7 causes slowdowns in circular perimeters; fixed in 4.8
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Diane Bruce
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-18 11:01 UTC by Sebastian
Modified: 2020-11-22 20:39 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (db)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian 2020-11-18 11:01:02 UTC
In Cura version 4.7 a bug regarding slowdowns in circular perimeters was introduced (or at list gets triggered much more easily than in earlier versions):
https://github.com/Ultimaker/Cura/issues/8321

This issue makes v4.7.x hardly usable.
Sticking to v4.5 has become quite "tricky" to say the least, due to the massive python-induced dependency hell and lots of dependencies being too new and/or incompatible for the 4.5 version.

Version 4.8 has been released on November 10 that fixes this glitch in the simplification algorithm. The issue is still open, but is considered to be solved with 4.8 and changed default settings for Maximum resolution and Maximum Deviation.

From the Changelog of 4.8:
Fixed under-simplification (blobs, zits) on some printer models. An oversight in 4.6.x resulted in an oversimplification (smoothing) of models. The attempted fix in 4.7.x overcompensated, which gave difficulty (zits, blobs) for some printer models when the resulting gcode became too intricate. This is now fixed, though some profiles might need to be updated, since they where made against 4.6.x, and therefore may rely on the over-simplification.


Would it be possible to fast-forward to 4.8?
Comment 1 commit-hook freebsd_committer 2020-11-20 23:04:18 UTC
A commit references this bug:

Author: db
Date: Fri Nov 20 23:03:25 UTC 2020
New revision: 555795
URL: https://svnweb.freebsd.org/changeset/ports/555795

Log:
  From PR:

  In Cura version 4.7 a bug regarding slowdowns in circular perimeters was
  introduced (or at list gets triggered much more easily than in earlier
  versions):
  https://github.com/Ultimaker/Cura/issues/8321

  This issue makes v4.7.x hardly usable.
  Sticking to v4.5 has become quite "tricky" to say the least, due to
  the massive python-induced dependency hell and lots of dependencies
  being too new and/or incompatible for the 4.5 version.

  Version 4.8 has been released on November 10 that fixes this glitch in
  the simplification algorithm. The issue is still open, but is considered
  to be solved with 4.8 and changed default settings for Maximum resolution
  and Maximum Deviation.

  From the Changelog of 4.8:
  Fixed under-simplification (blobs, zits) on some printer models. An oversight
  in 4.6.x resulted in an oversimplification (smoothing) of models.
  The attempted fix in 4.7.x overcompensated, which gave difficulty
  (zits, blobs) for some printer models when the resulting gcode became
  too intricate. This is now fixed, though some profiles might need
  to be updated, since they where made against 4.6.x, and therefore may
  rely on the over-simplification.

  PR:			ports/251236
  Submitted by:		Sebastian <sko@rostwald.de>

Changes:
  head/cad/cura/Makefile
  head/cad/cura/distinfo