Bug 252684 - Making graphics/embree depend on onetbb
Summary: Making graphics/embree depend on onetbb
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Alexey Dokuchaev
URL:
Keywords:
Depends on:
Blocks: 252648
  Show dependency treegraph
 
Reported: 2021-01-14 21:29 UTC by Ganael LAPLANCHE
Modified: 2021-02-19 21:19 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (danfe)
martymac: maintainer-feedback? (danfe)


Attachments
Patch to use onetbb (586 bytes, patch)
2021-01-14 21:29 UTC, Ganael LAPLANCHE
martymac: maintainer-approval? (danfe)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ganael LAPLANCHE freebsd_committer 2021-01-14 21:29:20 UTC
Created attachment 221580 [details]
Patch to use onetbb

Hello,

As a maintainer of graphics/embree, could you have a look at PR #252648:

  https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=252648

In short, TBB version 2021 will soon be available as devel/onetbb and (good news!) the port you maintain seems to build correctly with that new version, see the following Poudriere run:

  http://box.martymac.org/FreeBSD-Packages/build.html?mastername=FBSD122amd64-tbb-migr&build=2021-01-13_22h35m17s

and build log:

http://box.martymac.org/FreeBSD-Packages/data/FBSD122amd64-tbb-migr/2021-01-13_22h35m17s/logs/embree-3.12.1.log

Can you check the port and see if it is working as intended with the attached patch ?

If yes, please agree with the patch *by replying to this PR* (important), that will help me synchronize the changes.

To help you testing your port, expected patches to devel/tbb and devel/onetbb are available in PR #252648.

Thanks for your contribution,
Best regards,

Ganael.
Comment 1 Ganael LAPLANCHE freebsd_committer 2021-02-19 21:19:49 UTC
Patch committed (maintainer timeout)