Bug 257064 - x11-themes/kde-icons-black-and-white: Fix MASTER_SITES (Authentication error)
Summary: x11-themes/kde-icons-black-and-white: Fix MASTER_SITES (Authentication error)
Status: Closed DUPLICATE of bug 257242
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords: easy
Depends on:
Blocks:
 
Reported: 2021-07-08 22:58 UTC by Chris Hutchinson
Modified: 2021-07-29 21:49 UTC (History)
4 users (show)

See Also:
koobs: maintainer-feedback? (amdmi3)
koobs: merge-quarterly?


Attachments
git diff to update MASTER_SITES for x11-themes/kde-icons-black-and-white (1.40 KB, patch)
2021-07-08 22:58 UTC, Chris Hutchinson
portmaster: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Hutchinson 2021-07-08 22:58:37 UTC
Created attachment 226314 [details]
git diff to update MASTER_SITES for x11-themes/kde-icons-black-and-white

I'm getting messages from pkg-fallout@ at least twice
per day indicating that the source is unavailable:

=> black%20and%20white.tar.gz doesn't seem to exist in /portdistfiles/KDE.
=> Attempting to fetch http://mirror.amdmi3.ru/distfiles/KDE/black%20and%20white.tar.gz
34374359624:error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version:/usr/src/crypto/openssl/ssl/s23_clnt.c:802:
fetch: http://mirror.amdmi3.ru/distfiles/KDE/black%20and%20white.tar.gz: Authentication error
=> Attempting to fetch http://distcache.FreeBSD.org/ports-distfiles/KDE/black%20and%20white.tar.gz
fetch: http://distcache.FreeBSD.org/ports-distfiles/KDE/black%20and%20white.tar.gz: Not Found
=> Couldn't fetch it - please try to retrieve this
=> port manually into /portdistfiles/KDE and try again.
*** Error code 1

The git diff attached to this pr reconciles that
(provides a reliable source mirror)

Changes:
Makefile: MASTER_SITES
distinfo

Thats it.

Thanks

--Chris
Comment 1 Chris Hutchinson 2021-07-08 23:07:16 UTC
Proof the changes work:

# make distclean
===>  Cleaning for kde-icons-black-and-white-2.0.a
===>  Deleting distfiles for kde-icons-black-and-white-2.0.a

# make -DBATCH fetch
===>  License theme theme accepted by the user
===>   kde-icons-black-and-white-2.0.a depends on file: /usr/local/sbin/pkg - found
=> black-and-white.tar.gz doesn't seem to exist in /usr/ports/distfiles/KDE.
=> Attempting to fetch https://BSDforge.com/projects/source/x11-themes/kde-icons-black-and-white/black-and-white.tar.gz
black-and-white.tar.gz                                6546 kB  396 MBps    00s
===> Fetching all distfiles required by kde-icons-black-and-white-2.0.a for building

#
Comment 2 Chris Hutchinson 2021-07-10 17:42:19 UTC
Still a problem...

Subject: [package - 114i386-quarterly][x11-themes/kde-icons-black-and-white] Failed for kde-icons-black-and-white-2.0.a in fetch

Date: Sat, 10 Jul 2021 01:20:07 GMT

===>  License theme theme accepted by the user
=> black%20and%20white.tar.gz doesn't seem to exist in /portdistfiles/KDE.
=> Attempting to fetch http://mirror.amdmi3.ru/distfiles/KDE/black%20and%20white.tar.gz
673225192:error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version:/usr/src/crypto/openssl/ssl/s23_clnt.c:802:
fetch: http://mirror.amdmi3.ru/distfiles/KDE/black%20and%20white.tar.gz: Authentication error
=> Attempting to fetch http://distcache.FreeBSD.org/ports-distfiles/KDE/black%20and%20white.tar.gz
fetch: http://distcache.FreeBSD.org/ports-distfiles/KDE/black%20and%20white.tar.gz: Not Found
=> Couldn't fetch it - please try to retrieve this
=> port manually into /portdistfiles/KDE and try again.
*** Error code 1

and...

Subject: [package - 114amd64-quarterly][x11-themes/kde-icons-black-and-white] Failed for kde-icons-black-and-white-2.0.a in fetch

Date: Sat, 10 Jul 2021 01:21:19 GMT

===>  License theme theme accepted by the user
=> black%20and%20white.tar.gz doesn't seem to exist in /portdistfiles/KDE.
=> Attempting to fetch http://mirror.amdmi3.ru/distfiles/KDE/black%20and%20white.tar.gz
34374359624:error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version:/usr/src/crypto/openssl/ssl/s23_clnt.c:802:
fetch: http://mirror.amdmi3.ru/distfiles/KDE/black%20and%20white.tar.gz: Authentication error
=> Attempting to fetch http://distcache.FreeBSD.org/ports-distfiles/KDE/black%20and%20white.tar.gz
fetch: http://distcache.FreeBSD.org/ports-distfiles/KDE/black%20and%20white.tar.gz: Not Found
=> Couldn't fetch it - please try to retrieve this
=> port manually into /portdistfiles/KDE and try again.
*** Error code 1
Comment 3 Chris Hutchinson 2021-07-10 17:51:40 UTC
just got another....

Subject: [package - 114i386-default][x11-themes/kde-icons-black-and-white] Failed for kde-icons-black-and-white-2.0.a in fetch

Date: Sat, 10 Jul 2021 09:17:56 GMT

===>  License theme theme accepted by the user
=> black%20and%20white.tar.gz doesn't seem to exist in /portdistfiles/KDE.
=> Attempting to fetch http://mirror.amdmi3.ru/distfiles/KDE/black%20and%20white.tar.gz
673225192:error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version:/usr/src/crypto/openssl/ssl/s23_clnt.c:802:
fetch: http://mirror.amdmi3.ru/distfiles/KDE/black%20and%20white.tar.gz: Authentication error
=> Attempting to fetch http://distcache.FreeBSD.org/ports-distfiles/KDE/black%20and%20white.tar.gz
fetch: http://distcache.FreeBSD.org/ports-distfiles/KDE/black%20and%20white.tar.gz: Not Found
=> Couldn't fetch it - please try to retrieve this
=> port manually into /portdistfiles/KDE and try again.
*** Error code 1


I'm not trying to spam the pr logs here. Just attempting to
indicate that this apprears to happen for all attempts the
package builders make to build this port.

I'll stop now. :-)

--Chris
Comment 4 Tobias C. Berner freebsd_committer 2021-07-16 07:38:31 UTC
Moin moin 

(In reply to Chris Hutchinson from comment #3)
x11-themes/kde-icons-black-and-white> make fetch checksum                                        
===>  License theme theme accepted by the user
===>   kde-icons-black-and-white-2.0.a depends on file: /usr/local/sbin/pkg - found
=> black%20and%20white.tar.gz doesn't seem to exist in /nfs/distfiles/KDE.
=> Attempting to fetch http://mirror.amdmi3.ru/distfiles/KDE/black%20and%20white.tar.gz
black%20and%20white.tar.gz                            6546 kB   11 MBps    01s
===> Fetching all distfiles required by kde-icons-black-and-white-2.0.a for building
=> SHA256 Checksum OK for KDE/black%20and%20white.tar.gz.



is this still an issue? seems to fetch fine for me.
Comment 5 Guangyuan Yang freebsd_committer 2021-07-18 06:05:51 UTC
Seems to be fine for me - closing the PR. Please feel free to reopen if there is still an issue.

➜ kde-icons-black-and-white (main) ✔ make fetch checksum
===>  License theme theme accepted by the user
===>   kde-icons-black-and-white-2.0.a depends on file: /usr/local/sbin/pkg - found
=> black%20and%20white.tar.gz doesn't seem to exist in /usr/home/guangyuan/freebsd-ports-pub/distfiles/KDE.
=> Attempting to fetch http://mirror.amdmi3.ru/distfiles/KDE/black%20and%20white.tar.gz
black%20and%20white.tar.gz                            6546 kB 1040 kBps    07s
===> Fetching all distfiles required by kde-icons-black-and-white-2.0.a for building
=> SHA256 Checksum OK for KDE/black%20and%20white.tar.gz.
Comment 6 Chris Hutchinson 2021-07-20 16:35:58 UTC
OK now that was just rude.
I have some 20 or more emails from pkg-fallout@ for
failure to obtain the source for this port.
Because it worked (each) of you once. I have to
continue to take pkg-fallout? The patch (cure)
is trivial. Please commit it.

Thank you for your attention to this.

--Chris
Comment 7 Chris Hutchinson 2021-07-20 16:57:50 UTC
Sorry. I'm afraid *I* was being rude.
But yes. It's still a problem.

Please commit.

Thanks.
Comment 8 Kubilay Kocak freebsd_committer freebsd_triage 2021-07-21 01:26:10 UTC
Triage: Request feedback from amdmi3, the apparent MASTER_SITES owner
Comment 9 Dmitry Marakasov freebsd_committer 2021-07-23 13:28:53 UTC
I'm experimenting with dropping TLS1.2 support on my servers, that's likely the cause of errors on 11.x with its ancient openssl. For now TLS1.2 is back on, but it'll be permanently dropped in august. Anyway I'm not even sure why I'm hosting this garbage, feel free to remove by mirror from MASTER_SITES.
Comment 10 Chris Hutchinson 2021-07-29 21:49:40 UTC
Closing this as a duplicate of bug #257242.
As I can "kill 2 birds with one stone" and so
can the committer that handles it. :-)

Thanks!

--Chris

*** This bug has been marked as a duplicate of bug 257242 ***