Bug 259390 - audio/soundtouch: Fails to fetch: Service Unavailable
Summary: audio/soundtouch: Fails to fetch: Service Unavailable
Status: Closed DUPLICATE of bug 259173
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Many People
Assignee: Chris Rees
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2021-10-24 00:22 UTC by Christopher
Modified: 2021-10-24 09:25 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (crees)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher 2021-10-24 00:22:16 UTC
Are the URL's to fetch v2.3.1 correct?  I am running into issues updating multiple workstations.  Here's what I am seeing:

===>  Cleaning for soundtouch-2.3.1
===>  License LGPL21 accepted by the user
===>   soundtouch-2.3.1 depends on file: /usr/local/sbin/pkg - found
=> soundtouch-soundtouch-e1f315f5358d9db5cee35a7a2886425489fcefe8_GL0.tar.gz doesn't seem to exist in /usr/ports/distfiles//.
=> Attempting to fetch https://gitlab.com/soundtouch/soundtouch/-/archive/e1f315f5358d9db5cee35a7a2886425489fcefe8.tar.gz?dummy=/soundtouch-soundtouch-e1f315f5358d9db5cee35a7a2886425489fcefe8_GL0.tar.gz
fetch: https://gitlab.com/soundtouch/soundtouch/-/archive/e1f315f5358d9db5cee35a7a2886425489fcefe8.tar.gz?dummy=/soundtouch-soundtouch-e1f315f5358d9db5cee35a7a2886425489fcefe8_GL0.tar.gz: Service Unavailable
=> Attempting to fetch http://distcache.FreeBSD.org/ports-distfiles/soundtouch-soundtouch-e1f315f5358d9db5cee35a7a2886425489fcefe8_GL0.tar.gz
fetch: http://distcache.FreeBSD.org/ports-distfiles/soundtouch-soundtouch-e1f315f5358d9db5cee35a7a2886425489fcefe8_GL0.tar.gz: Not Found
=> Couldn't fetch it - please try to retrieve this
=> port manually into /usr/ports/distfiles// and try again.
*** Error code 1

The "distcache.FreeBSD.org" URL is a 404 error.  And, the "gitlab.com" seems to be an "unauthorized" error.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2021-10-24 01:18:11 UTC
@Reporter The initial fetch error indicates "Service Unavailable" which tends to be a transient issue. Is the issue still reproducible?
Comment 2 tech-lists 2021-10-24 01:38:28 UTC
If you go to the gitlab url in firefox, this happens:

Checking your browser before accessing gitlab.com.

This process is automatic. Your browser will redirect to your requested content shortly.

Please allow up to 5 seconds…

...and it never completes

If I go to the gitlab url in dooble, I get the same page but after 5 seconds I'm presented with a login screen https://gitlab.com/users/sign_in
Comment 3 Christopher 2021-10-24 02:18:07 UTC
Yes. Just tried again.

I noticed the problem yesterday, Friday October 22, 2021 and gave it 24 hours before reporting as I thought maybe something was down somewhere.

Is there another places where I can manually download:

soundtouch-soundtouch-e1f315f5358d9db5cee35a7a2886425489fcefe8_GL0.tar.gz

I checked on http://www.surina.net/ but they don't use the same file naming format so I assume that won't work.
Comment 4 Christopher 2021-10-24 02:24:27 UTC
(In reply to tech-lists from comment #2)
My firefox after about the 5 seconds or so that you reported actually takes me to a page that says "you must be logged in to access... bla bla" and then I get the login screen.  However, sometimes I get... your tab has crashed.

All of it making me things something is up with the URLs.  Maybe somebody upstream accidentally password protected the directory or file.  I don't know... just guessing...
Comment 5 Daniel Engberg freebsd_committer 2021-10-24 09:25:21 UTC
See https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=259173

*** This bug has been marked as a duplicate of bug 259173 ***