Bug 259479 - multimedia/tautulli: Update to 2.7.7
Summary: multimedia/tautulli: Update to 2.7.7
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dries Michiels
URL: https://github.com/Tautulli/Tautulli/...
Keywords: needs-qa
: 259480 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-10-27 10:26 UTC by Michiel van Baak Jansen
Modified: 2021-12-09 18:20 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (christer.edwards)


Attachments
0001-multimedia-tautulli-Update-to-2.7.7.patch (2.32 KB, patch)
2021-10-27 10:26 UTC, Michiel van Baak Jansen
koobs: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michiel van Baak Jansen 2021-10-27 10:26:47 UTC
Created attachment 229066 [details]
0001-multimedia-tautulli-Update-to-2.7.7.patch

testport ok
runs in production in my setup (FreeBSD 13.0 amd64)
Comment 1 Michiel van Baak Jansen 2021-10-27 10:29:33 UTC
*** Bug 259480 has been marked as a duplicate of this bug. ***
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2021-12-01 22:43:02 UTC
@Reporter Can you confirm QA on this (testport poudriere in particular). Additionally could you explain rationale (why) for the following changes:

 -    'CHECK_GITHUB': (int, 'General', 1),
 +    'CHECK_GITHUB': (int, 'General', 0),
..
 -     'CLEANUP_FILES': (int, 'General', 0),
 +     'CHECK_GITHUB_CACHE_SECONDS': (int, 'Advanced', 3600),

If these are based on upstream commits/bugs/pr's, please include a comment in the patch header with links to those upstream references too, thank you!
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2021-12-01 22:44:07 UTC
Comment on attachment 229066 [details]
0001-multimedia-tautulli-Update-to-2.7.7.patch

Pending QA:

Approved by: portmgr (maintainer timeout)
Comment 4 Michiel van Baak Jansen 2021-12-02 09:28:03 UTC
(In reply to Kubilay Kocak from comment #2)

This is the same patch as we always had, just rebased on the latest 2.7.7 sources.
It disables update checks against github:

- 'CHECK_GITHUB': (int, 'General', 1),
+ 'CHECK_GITHUB': (int, 'General', 0),

The other 2 changes in the .patch are because the source changed the file a bit.

As stated on the initial upload of the patch:

poudriere testport ok
runs in production in my setup
Comment 5 Dries Michiels freebsd_committer 2021-12-07 16:12:38 UTC
Take
Comment 6 commit-hook freebsd_committer 2021-12-09 18:19:28 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=849bacb55c2c38a41c485181bdb270dd46df60d2

commit 849bacb55c2c38a41c485181bdb270dd46df60d2
Author:     Michiel van Baak <michiel@vanbaak.eu>
AuthorDate: 2021-12-08 15:07:29 +0000
Commit:     Dries Michiels <driesm@FreeBSD.org>
CommitDate: 2021-12-09 18:16:39 +0000

    multimedia/tautulli: Update to 2.7.7

    While here switch to DISTVERSION, pet portclippy and portfmt.

    Changes:                https://github.com/Tautulli/Tautulli/releases/tag/v2.7.7
    PR:                     259479
    Approved by:            portmgr (maintainer timeout), philip (mentor)
    Differential Revision:  https://reviews.freebsd.org/D33336

 multimedia/tautulli/Makefile                     | 25 ++++++++++++------------
 multimedia/tautulli/distinfo                     |  6 +++---
 multimedia/tautulli/files/patch-plexpy_config.py |  8 ++++----
 3 files changed, 20 insertions(+), 19 deletions(-)
Comment 7 Dries Michiels freebsd_committer 2021-12-09 18:20:49 UTC
Committed, thanks for the patch!