Bug 208176 - devel/libatomic_ops: fix build on arm
Summary: devel/libatomic_ops: fix build on arm
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm Any
: --- Affects Some People
Assignee: Rodrigo Osorio
URL:
Keywords:
: 220008 (view as bug list)
Depends on:
Blocks: 201763
  Show dependency treegraph
 
Reported: 2016-03-21 10:47 UTC by Otacílio de Araújo Ramos Neto
Modified: 2017-06-19 17:54 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (rodrigo)


Attachments
poudriere build log. (19.50 KB, text/plain)
2016-03-21 10:47 UTC, Otacílio de Araújo Ramos Neto
no flags Details
Failed build on on arm (via poudriere & qemu) (19.53 KB, text/plain)
2016-03-21 11:20 UTC, Sylvain Garrigues
no flags Details
fix build with clang 3.8.0 (1.16 KB, patch)
2016-03-21 18:15 UTC, Mikael Urankar
no flags Details | Diff
poudriere build log. (22.64 KB, text/plain)
2016-03-21 22:21 UTC, Otacílio de Araújo Ramos Neto
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Otacílio de Araújo Ramos Neto 2016-03-21 10:47:39 UTC
Created attachment 168449 [details]
poudriere build log.

libatomic_ops fails to compile to arm. 

OS version:
FreeBSD nostromo 11.0-CURRENT FreeBSD 11.0-CURRENT #0 r296898M: Wed Mar 16 14:17:09 BRT 2016     ota@nostromo:/usr/obj/usr/src/sys/GENERIC  amd64

clang verson: 
FreeBSD clang version 3.8.0 (tags/RELEASE_380/final 262564) (based on LLVM 3.8.0)

libatomic_ops version:
root@nostromo:/usr/ports/devel/libatomic_ops # svn info
Caminho: .
Working Copy Root Path: /usr/ports
URL: svn://svn.freebsd.org/ports/head/devel/libatomic_ops
Relative URL: ^/head/devel/libatomic_ops
Raiz do Repositório: svn://svn.freebsd.org/ports
UUID do repositório: 35697150-7ecd-e111-bb59-0022644237b5
Revisão: 411354
Tipo de Nó: diretório
Agendado: normal
Autor da Última Mudança: amdmi3
Revisão da Última Mudança: 395777
Data da Última Mudança: 2015-09-01 13:20:47 -0300 (ter, 01 set 2015)
Comment 1 Sylvain Garrigues 2016-03-21 11:20:35 UTC
Created attachment 168452 [details]
Failed build on on arm (via poudriere & qemu)

Same bug here. Attached is my build log.
Comment 2 Mikael Urankar freebsd_committer 2016-03-21 18:15:00 UTC
Created attachment 168461 [details]
fix build with clang 3.8.0

Clang 3.8.0 defines __ARM_ARCH_6KZ__, it was __ARM_ARCH_6K__ with clang 3.7.1. The attached patch should fix the issue.
Comment 3 Rodrigo Osorio freebsd_committer 2016-03-21 22:10:03 UTC
@mikael.urankar : fix sound good to me, do you have a build log to attach to your patch ?

@otacillio, sylvain: does the fix works for you ?
Comment 4 Otacílio de Araújo Ramos Neto 2016-03-21 22:21:13 UTC
Created attachment 168468 [details]
poudriere build log.

Build log after patch.
Comment 5 Otacílio de Araújo Ramos Neto 2016-03-21 22:22:07 UTC
Compiles fine here. Poudriere build log in the previous post.
Comment 6 Otacílio de Araújo Ramos Neto 2016-03-21 22:23:41 UTC
Comment on attachment 168468 [details]
poudriere build log.

Compiles fine here after patch.
Comment 7 commit-hook freebsd_committer 2016-03-21 22:32:30 UTC
A commit references this bug:

Author: rodrigo
Date: Mon Mar 21 22:32:04 UTC 2016
New revision: 411626
URL: https://svnweb.freebsd.org/changeset/ports/411626

Log:
  Fix compilation for arm

  PR:		208176
  Submitted by:	mikael.urankar@gmail.com

Changes:
  head/devel/libatomic_ops/files/
  head/devel/libatomic_ops/files/patch-src_atomic__ops_sysdeps_gcc_arm.h
Comment 8 Rodrigo Osorio freebsd_committer 2016-03-21 22:34:10 UTC
committed, thanks.
Comment 9 Sylvain Garrigues 2016-03-22 10:34:11 UTC
Compile fines too here now.
Comment 10 Mikael Urankar freebsd_committer 2017-06-15 09:58:31 UTC
Hi,

The latest update broke armv6, files/patch-src_atomic__ops_sysdeps_gcc_arm.h is still needed (same build failure).

thanks in advance
Comment 11 Otacílio de Araújo Ramos Neto 2017-06-15 14:52:16 UTC
Mikael reports that the latest update broke armv6.
Comment 12 Mikael Urankar freebsd_committer 2017-06-15 15:31:46 UTC
see also #220008
Comment 13 Rodrigo Osorio freebsd_committer 2017-06-16 17:16:50 UTC
*** Bug 220008 has been marked as a duplicate of this bug. ***
Comment 14 Rodrigo Osorio freebsd_committer 2017-06-16 17:19:27 UTC
Does the existing patch fix the issue ? 
(https://bugs.freebsd.org/bugzilla/attachment.cgi?id=168461)
Comment 15 Mikael Urankar freebsd_committer 2017-06-19 08:16:32 UTC
Yes the patch is still needed. I created a PR:
https://github.com/ivmai/libatomic_ops/pull/26
Comment 16 Rodrigo Osorio freebsd_committer 2017-06-19 17:54:26 UTC
Patch reintroduced, thanks