Bug 225919 - net/liboauth: Fix build with OpenSSL 1.1
Summary: net/liboauth: Fix build with OpenSSL 1.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Hiroki Sato
URL: https://github.com/x42/liboauth/issues/9
Keywords:
: 232150 (view as bug list)
Depends on:
Blocks: 228865 231931
  Show dependency treegraph
 
Reported: 2018-02-15 15:15 UTC by Bernard Spil
Modified: 2018-10-23 13:58 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (hrs)


Attachments
svn diff for net/liboauth (4.66 KB, text/plain)
2018-02-15 15:15 UTC, Bernard Spil
no flags Details
Removed broken (5.11 KB, patch)
2018-09-16 00:32 UTC, Nathan
no flags Details | Diff
Removed broken (5.37 KB, patch)
2018-10-05 22:08 UTC, Nathan
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Bernard Spil freebsd_committer 2018-02-15 15:15:43 UTC
Created attachment 190650 [details]
svn diff for net/liboauth

```
net/liboauth: Fix build with OpenSSL 1.1

 - Currently doesn't build with OpenSSL 1.1

PR:
```

Working on updating the OpenSSL port to 1.1 which will require this patch
Comment 1 Bernard Spil freebsd_committer 2018-06-15 10:01:03 UTC
Now builds with OpenSSL 1.1, poudriere log https://keg.brnrd.eu/data/111amd64-default-openssl110/2018-06-11_10h42m37s/logs/liboauth-1.0.3_3.log
Comment 2 Bernard Spil freebsd_committer 2018-06-15 10:04:49 UTC
Need to remove BROKEN=
Comment 3 Nathan 2018-09-16 00:32:06 UTC
Created attachment 197122 [details]
Removed broken
Comment 4 Nathan 2018-10-04 11:31:15 UTC
Bernard don’t forget this fix. Watching exp-run of the OpenSSL
Comment 6 Nathan 2018-10-04 13:24:06 UTC
(In reply to Antoine Brodin from comment #5)
This patch fixed it with previous attempt of test
Comment 7 Antoine Brodin freebsd_committer 2018-10-05 21:45:44 UTC
(In reply to Nathan from comment #6)
There should be a PORTREVISION bump since the code changes.
Comment 8 Nathan 2018-10-05 22:08:14 UTC
Created attachment 197820 [details]
Removed broken

net/liboauth:
 
 * Fix openssl build
 
 PR:             225919
 Submitted by:   Nathan <ndowens@yahoo.com>
Comment 9 Antoine Brodin freebsd_committer 2018-10-10 18:32:16 UTC
*** Bug 232150 has been marked as a duplicate of this bug. ***
Comment 10 commit-hook freebsd_committer 2018-10-10 19:28:36 UTC
A commit references this bug:

Author: antoine
Date: Wed Oct 10 19:28:18 UTC 2018
New revision: 481766
URL: https://svnweb.freebsd.org/changeset/ports/481766

Log:
  Fix build with openssl 1.1.1

  PR:		225919
  Submitted by:	Nathan Owens
  Obtained from:	https://github.com/x42/liboauth/issues/9
  With hat:	portmgr

Changes:
  head/net/liboauth/Makefile
  head/net/liboauth/files/
  head/net/liboauth/files/patch-src_hash.c
Comment 11 commit-hook freebsd_committer 2018-10-19 13:05:00 UTC
A commit references this bug:

Author: antoine
Date: Fri Oct 19 13:04:29 UTC 2018
New revision: 482425
URL: https://svnweb.freebsd.org/changeset/ports/482425

Log:
  MFH: r481766

  Fix build with openssl 1.1.1

  PR:		225919
  Submitted by:	Nathan Owens
  Obtained from:	https://github.com/x42/liboauth/issues/9
  With hat:	portmgr

Changes:
_U  branches/2018Q4/
  branches/2018Q4/net/liboauth/Makefile
  branches/2018Q4/net/liboauth/files/
Comment 12 Koichiro Iwao freebsd_committer 2018-10-23 08:08:01 UTC
Close? Anything else to do?
Comment 13 O. Hartmann 2018-10-23 11:44:48 UTC
At least for me, the port builds under 13-CURRENT and 12-BETA1.
Comment 14 Koichiro Iwao freebsd_committer 2018-10-23 13:58:37 UTC
The fix already has been committed, closing.