Bug 234509 - [NEW PORT] lang/ruby26: Object-oriented interpreted scripting language (2.6)
Summary: [NEW PORT] lang/ruby26: Object-oriented interpreted scripting language (2.6)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Many People
Assignee: freebsd-ruby (Nobody)
URL: https://reviews.freebsd.org/D19961
Keywords: feature, needs-qa
: 235826 (view as bug list)
Depends on: 230289 230436 235795 235796
Blocks:
  Show dependency treegraph
 
Reported: 2018-12-30 18:24 UTC by pete
Modified: 2019-05-09 01:31 UTC (History)
3 users (show)

See Also:


Attachments
Initial ruby26 patch (350.28 KB, patch)
2018-12-30 18:24 UTC, pete
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description pete 2018-12-30 18:24:59 UTC
Created attachment 200630 [details]
Initial ruby26 patch

As per this thread on the ports mailing list work has been started by Yasuhiro KIMURA to create a lang/ruby26 port.  As per the mailing list discussion it has been proposed to no longer exclude rake, gem, minitest, and bundler from the main port.

Attached is the initial patch proposal, it builds and the ruby runtime seems to work on both 12-RELEASE and 13-CURRENT (amd64).  There is an issue with running bundler26 though that will need to be resolved:

$ /usr/local/bin/bundle26 
Traceback (most recent call last):
	2: from /usr/local/bin/bundle26:23:in `<main>'
	1: from /usr/local/lib/ruby/2.6/rubygems.rb:302:in `activate_bin_path'
/usr/local/lib/ruby/2.6/rubygems.rb:283:in `find_spec_for_exe': can't find gem bundler (>= 0.a) with executable bundle (Gem::GemNotFoundException)
$



Filing this PR as a starting place for discussion on getting ruby26 into the ports tree.  To apply the patch copy lang/ruby25/ to lang/ruby26/, then apply and build.
Comment 1 pete 2018-12-30 18:29:50 UTC
(In reply to pete from comment #0)
Link to original mailing list discussion:
https://lists.freebsd.org/pipermail/freebsd-ports/2018-December/115182.html
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2018-12-31 05:25:43 UTC
@Pete 

Thank you for your contribution

A work in progress like this is likely better suited to a Phabricator review/differential, until it is 'ready'. Happy for this issue to continue to exist as a central coordination point though.

Could you please:

- Create a review
- Add the review URL here
- Obsolete the existing attachment
Comment 3 Koichiro Iwao freebsd_committer 2019-04-03 13:36:52 UTC
*** Bug 235826 has been marked as a duplicate of this bug. ***
Comment 4 Koichiro Iwao freebsd_committer 2019-04-19 01:21:28 UTC
I'll create a review based on pete and Yasuhiro Kimura's work.
Comment 5 Koichiro Iwao freebsd_committer 2019-04-19 02:54:21 UTC
Could not submit a review due to 233177. Is there any phabricator alternatives?
Comment 6 Koichiro Iwao freebsd_committer 2019-05-07 06:11:15 UTC
All dependent bugs are solved. Ready to land.
Comment 7 Koichiro Iwao freebsd_committer 2019-05-09 00:20:36 UTC
It seems nobody is interested in Ruby 2.6 :(
Comment 8 commit-hook freebsd_committer 2019-05-09 01:29:17 UTC
A commit references this bug:

Author: meta
Date: Thu May  9 01:28:40 UTC 2019
New revision: 501068
URL: https://svnweb.freebsd.org/changeset/ports/501068

Log:
  Add ruby26 2.6.3 (copied from ruby25)

  PR:		234509 235826
  Submitted by:	pete@nomadlogic.org (initial revision)
  		Yasuhiro KIMURA <yasu@utahime.org> (initial revision)
  		meta (myself, minor modifications)
  Relnotes::	https://www.ruby-lang.org/en/news/2018/12/25/ruby-2-6-0-released/
  		https://www.ruby-lang.org/en/news/2019/01/30/ruby-2-6-1-released/
  		https://www.ruby-lang.org/en/news/2019/03/13/ruby-2-6-2-released/
  		https://www.ruby-lang.org/en/news/2019/04/17/ruby-2-6-3-released/
  Differential Revision:	https://reviews.freebsd.org/D19961

Changes:
  head/Mk/bsd.default-versions.mk
  head/Mk/bsd.ruby.mk
  head/lang/ruby26/
  head/lang/ruby26/Makefile
  head/lang/ruby26/distinfo
  head/lang/ruby26/files/patch-configure.ac
  head/lang/ruby26/files/patch-tool_rbinstall.rb
  head/lang/ruby26/pkg-message
  head/lang/ruby26/pkg-plist
Comment 9 Koichiro Iwao freebsd_committer 2019-05-09 01:31:04 UTC
Committed, thank you both for your great work!