Bug 253483 - FreeBSD 13 beta 2.amd64.iso is too large for single DVD
Summary: FreeBSD 13 beta 2.amd64.iso is too large for single DVD
Status: Closed Overcome By Events
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: 13.0-STABLE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Mark Linimon
URL:
Keywords:
: 255057 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-02-13 13:34 UTC by Lloyd Osten
Modified: 2021-07-22 00:07 UTC (History)
9 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lloyd Osten 2021-02-13 13:34:51 UTC
I tried burning the FreeBSD 13 beta 2.amd64.iso onto a 4.7G DVD with K3B. K3B wouldn't burn it, because it said the ISO was too large to fit on the DVD (4555 MB). I burned it to a dual-layer DVD with no problem....but I don't know how many people would have those...
Comment 1 Glen Barber freebsd_committer 2021-02-16 17:50:30 UTC
I do not think we are going to address this at this point in the release cycle, considering the ISOs can be dd(1)'d to a flash drive as well.
Comment 2 andrzej4bsd 2021-05-02 12:30:25 UTC
I have experienced the same issue. Currently I don't have any other DVD type nor Flash/USB.
Maybe I will try an older version or wait a bit for the fixed.
I just wanted to check how my machine supports FreeBSD, so nothing it's nothing urgent.

I have found this bug report recently, but earlier I have started this as a topic on the FreeBSD forum, if you need some details for reference:
https://forums.freebsd.org/threads/freebsd-13-0-amd64-dvd1-iso-is-too-large-to-fit-dvd.80184/#post-509329
Comment 3 Teran McKinney 2021-05-11 17:12:16 UTC
There's many usecases for optical media. They last much longer, can't be rewritten, and are great for archival. I like to burn FreeBSD release DVDs for this reason.

I understand having a memstick image, but if it's going to say DVD, it should be burnable to a DVD. I could understand having a Bluray image as well.

How much work would it take to get the DVD ISO down to DVD sizes and make another for BluRay or memstick that's larger?

disc1 has been too big for CD media for a while. I think it'd be nice to address that as well, but DVD is probably more important.
Comment 4 Graham Perrin 2021-05-12 02:42:33 UTC
There should be a corresponding documentation bug with regard to the misleading statement at https://www.freebsd.org/where/#choose-image
Comment 5 Mark Linimon freebsd_committer freebsd_triage 2021-06-30 00:21:24 UTC
^Triage: now see PR 256412.
Comment 6 Glen Barber freebsd_committer 2021-07-21 19:25:30 UTC
*** Bug 255057 has been marked as a duplicate of this bug. ***
Comment 7 unitrunker 2021-07-21 23:18:49 UTC
One reason to keep the DVD option around is there's lots of surplus ex-corporate hardware for sale where the BIOS password is long lost and not easily removed or reset.

I have one machine where I can't change device boot order because of this.
Comment 8 Glen Barber freebsd_committer 2021-07-22 00:07:35 UTC
Well, there is also the disc1.iso and bootonly.iso, which provide the same basic functionality - the only difference is bootonly.iso does not have the independent distribution sets (base.txz, kernel.txz, etc.), and disc1.iso does not have the (mainly desktop-specific) packages.

Both fit quite well on a DVD.