Bug 257449 - lang/pocl: Update to 1.8
Summary: lang/pocl: Update to 1.8
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Mikael Urankar
URL: http://portablecl.org/pocl-1.8.html
Keywords: needs-qa
: 257451 259433 (view as bug list)
Depends on:
Blocks: 255139
  Show dependency treegraph
 
Reported: 2021-07-27 10:32 UTC by O. Hartmann
Modified: 2021-11-10 11:44 UTC (History)
2 users (show)

See Also:
koobs: merge-quarterly?


Attachments
Update pocl 1.7 (7.17 KB, patch)
2021-07-27 10:32 UTC, O. Hartmann
no flags Details | Diff
Update POCL 1.8 (6.98 KB, patch)
2021-10-25 11:31 UTC, O. Hartmann
no flags Details | Diff
v0 (7.60 KB, patch)
2021-10-25 17:09 UTC, Mikael Urankar
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2021-07-27 10:32:51 UTC
Created attachment 226734 [details]
Update pocl 1.7

POCL 1.7 is out since May, this is a followup and upgrade of pocl with some minor fixes according to a chat with W. Losh. An initial (trivial) fix has been applied according to Bug 255139 , specifically "excess dependencies". Fixing docs is underway.
Comment 1 Li-Wen Hsu freebsd_committer 2021-07-27 13:03:28 UTC
(In reply to O. Hartmann from comment #0)
I got error in configure phase: https://gist.github.com/lwhsu/cc15978ff96d53afa81660c3afde6f19
Comment 2 O. Hartmann 2021-10-25 11:31:54 UTC
Created attachment 229018 [details]
Update POCL 1.8

Update to POCL 1.8:

Have CLOCK_MONOTONIC_FAST in favor over CLOCK_UPTIME_FAST (see files/patch-lib_CL_pocl_timing.c)
Enable aarch64, considered as experimental
Comment 3 O. Hartmann 2021-10-25 11:32:39 UTC
*** Bug 259433 has been marked as a duplicate of this bug. ***
Comment 4 Mikael Urankar freebsd_committer 2021-10-25 17:09:54 UTC
Created attachment 229027 [details]
v0

aarch64 needs the same fix as the one found in bug #257451
Your indentation looks very weird.
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2021-10-27 00:51:32 UTC
*** Bug 257451 has been marked as a duplicate of this bug. ***
Comment 6 Kubilay Kocak freebsd_committer freebsd_triage 2021-10-27 00:51:45 UTC
@Mikael Do you want to take this?
Comment 7 Mikael Urankar freebsd_committer 2021-10-27 07:47:57 UTC
(In reply to Kubilay Kocak from comment #6)
Nope, I won't have access to a computer for the next two weeks.
Comment 8 commit-hook freebsd_committer 2021-11-09 17:58:07 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=d25b263de3bc36fcc18c42b706fd4cd77ccf097d

commit d25b263de3bc36fcc18c42b706fd4cd77ccf097d
Author:     Mikael Urankar <mikael@FreeBSD.org>
AuthorDate: 2021-11-09 17:29:35 +0000
Commit:     Mikael Urankar <mikael@FreeBSD.org>
CommitDate: 2021-11-09 17:56:40 +0000

    lang/pocl: Update to 1.8

    PR:             257449

 lang/pocl/Makefile                             | 53 ++++++++++++++++----------
 lang/pocl/distinfo                             |  6 +--
 lang/pocl/files/patch-lib_CL_devices_cpuinfo.c | 40 ++++++++++---------
 lang/pocl/pkg-plist                            | 19 ++++-----
 4 files changed, 67 insertions(+), 51 deletions(-)