Bug 216637 - net-p2p/retroshare: fails to build with clang 4.0
Summary: net-p2p/retroshare: fails to build with clang 4.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords: needs-patch
Depends on:
Blocks: 216008
  Show dependency treegraph
 
Reported: 2017-01-30 23:53 UTC by Jan Beich
Modified: 2017-12-21 21:17 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (peter)


Attachments
patch-bdthreads.cc (381 bytes, text/x-c++src)
2017-12-19 06:05 UTC, Walter Schwarzenfeld
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2017-01-30 23:53:58 UTC
util/bdthreads.cc:132:10: error: ordered comparison between pointer and zero ('pthread_t' (aka 'pthread *') and 'int')
        if(mTid > 0)
           ~~~~ ^ ~

build log: http://package18.nyi.freebsd.org/data/headamd64PR216008-default/2017-01-29_16h09m05s/logs/errors/retroshare-0.6.1_4.log
regressed by: https://github.com/llvm-mirror/clang/commit/4b6ad14285f3
Comment 1 commit-hook freebsd_committer 2017-12-19 03:53:30 UTC
A commit references this bug:

Author: linimon
Date: Tue Dec 19 03:53:02 UTC 2017
New revision: 456703
URL: https://svnweb.freebsd.org/changeset/ports/456703

Log:
  Mark broken on arm due to regression in clang 4.0.

  PR:		216637
  Submitted by:	jbeich
  Approved by:	portmgr (tier-2 blanket), maintainer timeout (peter@netkey.at, several months)

Changes:
  head/net-p2p/retroshare/Makefile
Comment 2 Walter Schwarzenfeld freebsd_triage 2017-12-19 06:05:49 UTC
Created attachment 188949 [details]
patch-bdthreads.cc

Compiles fine with the  patch (only 10.4 tested).
Comment 3 commit-hook freebsd_committer 2017-12-21 21:01:57 UTC
A commit references this bug:

Author: dim
Date: Thu Dec 21 21:01:38 UTC 2017
New revision: 456947
URL: https://svnweb.freebsd.org/changeset/ports/456947

Log:
  Fix build of net-p2p/retroshare with recent versions of clang.

  Approved by:	portmgr blanket
  Submitted by:	Walter Schwarzenfeld <w.schwarzenfeld@utanet.at>
  PR:		216637
  MFH:		2017Q4

Changes:
  head/net-p2p/retroshare/Makefile
  head/net-p2p/retroshare/files/patch-libbitdht_src_util_bdthreads.cc