Bug 216194 - misc/sword: fails to build with clang 4.0
Summary: misc/sword: fails to build with clang 4.0
Status: Closed DUPLICATE of bug 225276
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Thomas Abthorpe
URL:
Keywords: needs-patch
Depends on:
Blocks: 216008
  Show dependency treegraph
 
Reported: 2017-01-17 21:31 UTC by Jan Beich
Modified: 2018-01-17 19:06 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (tabthorpe)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2017-01-17 21:31:10 UTC
../src/keys/treekeyidx.cpp:64:12: error: ordered comparison between pointer and zero ('sword::FileDesc *' and 'int')
        if (datfd <= 0) {
            ~~~~~ ^  ~
../src/keys/treekeyidx.cpp:334:12: error: ordered comparison between pointer and zero ('sword::FileDesc *' and 'int')
        if (datfd > 0) {
            ~~~~~ ^ ~
../src/keys/treekeyidx.cpp:388:12: error: ordered comparison between pointer and zero ('sword::FileDesc *' and 'int')
        if (idxfd > 0) {
            ~~~~~ ^ ~
../src/keys/treekeyidx.cpp:425:12: error: ordered comparison between pointer and zero ('sword::FileDesc *' and 'int')
        if (idxfd > 0) {
            ~~~~~ ^ ~
../src/keys/treekeyidx.cpp:491:12: error: ordered comparison between pointer and zero ('sword::FileDesc *' and 'int')
        if (idxfd > 0) {
            ~~~~~ ^ ~

build log: http://sprunge.us/jLhO
regressed by: https://github.com/llvm-mirror/clang/commit/4b6ad14285f3
Comment 1 Jan Beich freebsd_committer 2018-01-17 19:06:54 UTC

*** This bug has been marked as a duplicate of bug 225276 ***