Bug 216355 - www/domoticz: fails to build with clang 4.0
Summary: www/domoticz: fails to build with clang 4.0
Status: Closed DUPLICATE of bug 221118
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords: needs-patch
Depends on:
Blocks: 216008
  Show dependency treegraph
 
Reported: 2017-01-21 19:10 UTC by Jan Beich
Modified: 2018-01-22 10:27 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (kiwi)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2017-01-21 19:10:43 UTC
hardware/HarmonyHub.cpp:219:46: error: ordered comparison between pointer and zero ('void *' and 'int')
                                if (memset(m_databuffer, 0, BUFFER_SIZE) > 0)
                                    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ^ ~
hardware/HarmonyHub.cpp:812:42: error: ordered comparison between pointer and zero ('void *' and 'int')
                if(memset(m_databuffer, 0, BUFFER_SIZE)>0)
                   ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^~

build log: http://sprunge.us/WIaP
regressed by: https://github.com/llvm-mirror/clang/commit/4b6ad14285f3
Comment 1 kiwi 2017-07-31 11:56:44 UTC
Fixed in 221118
Comment 2 Walter Schwarzenfeld freebsd_triage 2018-01-22 09:21:34 UTC
Forgotten to close?
Comment 3 kiwi 2018-01-22 09:34:01 UTC
(In reply to w.schwarzenfeld from comment #2)

Seems so...
Comment 4 Jan Beich freebsd_committer 2018-01-22 10:27:14 UTC
I confirm, it builds fine with Clang 4.0.

http://beefy9.nyi.freebsd.org/data/latest-per-pkg/domoticz/3.8153_2/111amd64-default.log
http://beefy10.nyi.freebsd.org/data/latest-per-pkg/domoticz/3.8153_2/111i386-default.log

*** This bug has been marked as a duplicate of bug 221118 ***